First test problem


i made my first run with easel to check how everything move and behave, i have to say i have not yet installed limit switches wich i belive is where my problem comes from, but anyways the thing is all my axis move fine, before you start carving easel ask you to zero your machine, wich i do, all good and then i hit carve, but no matter what or where in the workarea i tell it to work, the first thing the machine does is to move to the end of the x and y axis and start hitting against itselft (as there is nothing to tell it, it has reached the end of the axis), my question is this normal? is there a way i can set up it to carve without the limit switches? What can i do to solve it?

You can turn off the limit/homing switch capability in easel in the machine set up. As you go through the various pieces, when it asks to home, provide the indication that you don’t want to use that feature. I use my machine that way with no issues. If you do this and still have problems you may want to look for loose wires anywhere from the gshield to each of the steppers. Seems to be a common culprit.

i turned off the homing capability but even like that the machines does th same, it move to the end of both axis and start slaming into it. About the wires i checked too, but couldn’t find anything, if my steppers move fine in all directions wouldn’t that mean that the motors are set up correctly?

thanks for the help btw.

Likely not a big help here, but check mm versus inches in your set up. G20 (inch) versus G21 (metric). I mixed that up once and found my system doing similar things as you describe. If you go to the advanced section of the machine setup you should be able to see that detail. You can export your gcode and review it for the G20 or G21. It should be listed at the beginning of the code.

Yes it was a bad configuration of the grbl, i fixed it by re flashing it. Thanks!