[fixed] Can't import SVG file from inkscape

I’m quite new to all this - so please excuse any stupid things I say - but will do my best. Last week I designed a part in Inkscape and imported the svg to easel & carved it out. Worked great. Now, this week, Easel doesn’t show my part after I import it at all. Very strange. Worked great last week. Is anyone else having this issue, or am I missing something. Both Inkscape & Easel are set to inches. Just like last week. I can design a circle in easel, and care it out fine, but can’t import anything from Inkscape this week. Has something changed? I’m on a windows 7 PC. Thanks so much.

I’m even newer than you, since I don’t have a tool yet.

One thing that happened to me is that I “lost” a part in Easel. It came in white and I couldn’t see it very well. Had to randomly select the whole board for it to pick up the piece, and when I set my depth to a reasonable cut I could finally see it.

Thanks for that pointer. That doesn’t seem to be my situation - I tried it - but no luck. I did notice, though, that there is some very tiny red marks on the 3D rendering on the right side of the screen in easel - so maybe it is importing the piece as an extremely small, tiny piece - but can’t tell - both Inkscape & easel are set to inches, and it worked fine last week - that’s what is so strange here. Thanks!

@CharlesLewis is it the same file?

Yes, that’s what’s so strange - worked perfectly fine last week … same exact file - no changes at all.

If you click the Easel icon and open up the file in your online account from last week does it appear in that file?

Yes it does - perfectly - but I can’t import any svg file from Inkscape - new or old - really strange.

Please email the file to help@inventables.com and we’ll take a look.

Thank you, will do. But just to be clear - NO svg files from Inkscape will import to Easel now - not even one with just a simple circle - nothing works - including the files that worked perfectly 10 days ago. That’s why I’m wondering if some changes were made to Easel that resulted in NO inkscape svg files being able to import into Easel. Thank you for your help in this - I’m really confused by this.

Hi Charles,

First off, I’m really sorry that Easel is causing you trouble. I checked out your file, went back in time (code-wise) and tried it on a slightly older version of Easel and can confirm that it used to import fine like you said. That means we broke something. We are trying to figure out exactly what happened right now, and are working on fixing it and making sure it can’t happen again. I’ll update this thread when it is fixed.


@CharlesLewis sorry again for the inconvenience. We just deployed a fix for the SVG import bugs, you should be able to import those files now at their proper size!

Let me know if you have any other issues.


Thanks so much Paul, it works great again now. I really appreciate you looking in to this!

All the best,


I’ve got the same issue. Is it something I can fix?