FIXED: Mac connectivity issues

We started to have reports this week about Macs not connecting with people’s new machines. This issue was hard to track down: many people who had their X-Carve for a while seemed to be connecting fine, so it did not seem to be a bug in the Easel code. Based on how sudden the onset of the problem, and the fact that there were no code updates to this part of Easel recently, the only other culprit was the Arduino itself. However, the users affected were all able to connect to their machines using other software.

It turned out that there was an update recently to the way that the Arduinos were identifying themselves. Easel didn’t know about this and kept searching for the old style of Arduino ID.

We updated Easel a few minutes ago so that it will recognize the new Arduinos. Please refresh the page and you should be able to connect.

Thank you to everyone who reported issues and patiently helped us identify the problem. I’m very sorry for the inconvenience, but instead of just apologies I want you to know what we are doing now to prevent this problem.

We use an internal process called Root cause analysis to trace problems back beyond their immediate cause, back to the process that led to the error. I started a root cause analysis on this issue because it has to do with manufacturing, sourcing, fulfillment and development. The immediate corrective action has already been taken: we deployed a fix for Easel to allow it to recognize the new Arduinos (hooray web based software!). But now we have to figure out where this change occured, and modify / create a process so that it does not happen again. I’ll update this post with our findings.

Side note: this is not the same as the connection issues related to using the beta of El Capitan. That is being solved separately and will be fixed by the time the general release is available to the public.


Thanks @paulkaplan and the rest of the Inventables team for fixing this. I wasn’t one of the affected, but it is nice to see that those that were, will have a solution. I concur: “hooray web based software!”

1 Like

Woo hoo!

1 Like

Waiting with anticipation for the weekend to give this a try.

Is there a way you can confirm that the Electronic package is working properly?
Do you have access to a windows machine you can try it with?

Double and triple check that your gShield is well seated on the Arduino and that all wires are connected securely. Do you have a blue light on the gShield when it is on?

blinking lights… hmmm

Looks intermittent any chance that the gShield isn’t pushed all the way into the Arduino?

You haven’t installed anything Arduino have you… as in blink or used the Arduino app for anything?

Not running El Capitan are you?

I saw on the video that there is a little bar on chrome that has a warning on it… could it be blocked somehow?

Just trying to go through the different things I can think of that would have cause a problem like this.

I had the same problem the other day after first setting the machine up. I put electrical tape on the metal housing just incase since those pins were touching the metal. Im not sure how i got it to connect but it started working after the tape.

is your power supply set to the right voltage for that area? try completely shutting the computer down and restarting it, i know as a mac user i rarely shut mine down at all. im sure you have tried this also but turn the machine off then connect it to the computer then turn the machine on.
This thing has such a learning curve im baffled by all the stuff ive been reading.
Oh nice tape job!

Trying on a Windows machine, if you can, will at least help you rule out a few variables. I’m not recommending that you switch to Windows, just that if it works or not, we can narrow down the search.

Went to my office and got a PC laptop to bring home. Did all the drivers and steps and issue still happened the same as with my Mac… I have now deleted my posts from this thread as not to hijack it, and started my own topic at: [FIXED] Cannot connect to X-Carve (Mac or Windows)

1 Like