[fixed] SVG from Corel Draw x7

When I export anything from Corel Draw x7 as an SVG file, nothing gets imported into Easel. I have checked and those files are all readable by several other SVG readers. EASEL however, just shows a blank page.

What’s up with that?


Can you post the SVG file?

Absolutely Paul but I don’t see a way to attach it to the post - can you point me in the right direction?

Hi @ChetKloss when you are replying to the thread click the icon that looks like a bar with an up arrow. It’s the “upload” icon.

Also have you taken a look at the SVG import guide in Easel?

There is the file :slight_smile:

Yes I saw the guide. I understand about not embedding fonts and converting fonts to curves

Hi @ChetKloss

I’m just seeing if I can help a little…

Are you able to import this file? see attached

I’m feeling really stupid here but I don’t see the file attachment. (or anyway to download something)
I do see my SVG file visualized in the body of your message.
If it is any simpler, you can send it to me direct at chetkloss@outlook.com

Thanks for helping :slight_smile:

sending now in a zip file

Ok so this is definite progress. When I view that file with an SVG viewer it comes up exactly as I created it. When I bring it up in Easel, all the graphics show up (Yay!) but the layout is scrambled.

Your thoughts?

P.S. Thank you so much for the help.

any chance you can post a screen shot of what it looks like when it is scrambled?

ah, yep I just tried it and see what you are talking about… I think that is just the letters not being grouped… and coming in as separate pieces… let me test something out and I’ll post on the progress

Ok, I just tried a few different things and it looks like there is something funky with the vectors of the L and K…

What font did you use for the letters?

I fried recreating the file from scratch without copy and pasting the original vectors and it imported fine into Easel, so I am thinking that it is either a problem with that specific set of vectors or it could be an issue with how InkScape is creating the file.

Ok - before the fonts were converted to curves (which happens as part of the Corel Export to SVG process) they were of type Arial (true tyoe font).


Hi Chet,

Sorry about the issue. We are currently investigating an SVG import bug. Not sure just yet if it is the same as what you are experiencing, but I’ll keep you updated as we solve them!

Thanks Paul. It just good to know that the problem might not be between the seat and keyboard :smile:

Hi Chet,

We just pushed a fix for the SVG importing bug. I tried out your file and it seemed to be working. Let me know if you see anything else that is off!

Thanks for being patient with us!

1 Like

I did a simple file where I created some test in Corel and then exported it as an SVG (where it changes the text to curves) and everything worked great. Thank you very much :slight_smile:

Wonderful! Do you need to select any special settings for that to happen? Or to get it to export with the right units? I don’t have a copy of Corel Draw, but it would be nice to add any special instructions to the import guide if there is anything special you have to do.

Hi Paul,

I’m attaching a screen capture from Corel from the SVG export action that shows how you choose text as curves.
Thanks again for all your help.