Freezing mid run

Hi Guys,

Sorry of this is a repost, I had a brief look about and couldn’t see anything too similar. So on and off ever since I have had my machine (upgraded shapeoko 2), about 8 months, I have had freezing problems in both easel and UGS mid run. The spindle will stop moving and performing the cuts… often it appears to be during a plunge.

Anyway, I have tried many things to resolve this issue. Replacing the USB for one with two feral beads (correct spelling/terminology?) seemed to fix things for a short period of time. Then it started happening again. I can go for five or six separate runs with no issues, and then three attempts will stop in a row. Often at different stages so its not a timing of specific code line issue I think. I then thought It may be because I was running other machinery in the workshop at the same time because I noticed that when I ran the table saw or dust extractor it seemed to coincide with a few of the freezes. Then, today it decided to freeze whilst only the cnc was running.

I am curious if it is a laptop issue. My macbook pro is 5 years old, but in pretty good condition. I close all programmes down before loading easel or UGS and clear the RAM… does anyone have any ideas what is going on, or has anyone had similar issues?

Thanks

Simon

First, kudos for trying to search for a solution, always appreciated. I think you mean “ferrite” [ed: thanks @TimothyHanson] , but you were pretty close :smile:

I don’t recall seeing any other users with this problem. The only thing it’s bringing to mind is a user that was having some issues, and his solution was to use a powered USB hub, instead of plugging the Arduino directly into his computer. I believe the issue he was seeing was that the Arduino wasn’t showing up for his computer, but what made me think of it was you mentioning that it seemed to coincide with power fluxuations.

Also I’m assuming that your laptop isn’t going into sleep mode or anything like that? I’m sure you’ve already checked into that, but thought I would mention it just to make sure.

You can also contact Inventables help directly, their contact info is here: http://inventables.com/about

I don’t have anything else constructive to add as far as a solution, but Ferrite is the term everyone’s looking for. :smiley:

Learn something every day :slight_smile:

Haha thank you for the response guys, even Timothy :wink:

PJTX, you are right the laptop is plug in and i have ensured the settings are not letting it go to sleep. The powered usb hub is an interesting idea. It kind of feels like the arduino drops signal or connection to the laptop without actually disconnecting from easel or UGS. In fact now that you have me thinking about it, when it happens whilst using UGS the programme will the no longer respond to jogging commands. Maybe the usb ports on my laptop are the issue. Would a powered usb hub negate this? I think I may try it, unless anyone else has ideas?

Thanks again guys.

Simon