Frustrations with Easel

Greetings, new user that is getting a bit frustrated with Easel and the machine.

First, why is it that if I use UGS to home machine and set zero in Easel that will make machine position zero. But, if I use Easel and home machine it sets the zero at as work position not machine position?

Next, added a relay to power spindle on automatically. Makita router, relay purchased off Amazon, was a model I saw recommended here. Hook relay up everything works fine a few times. Then it starts getting buggy… turn spindle on in Easel, clicks and shuts the carve dialog box and does nothing. OR spindle starts makes one pass and then router shuts off program stops when 3 more passes are required.

So question is why can I not reset machine zero in Easel? Use the same command code as UGS and it resets work zero.

I purchased this machine off Craigslist from a fellow that bought a Longmill to replace it. Asked him why and he said for larger unit. I question whether that was the true reason or because these units are buggy and a pain in the butt to keep running?

You’re homing and setting zero in UGS and then switching to Easel? In doing that, you restarted the controller. You cannot set machine zero…it is determined by homing or by the location when powered on / reset.

Why are you trying to do this? Machine zero is just a reference for all other offsets. Your gcode is based on your WORK coordinate system.

The router stuff sounds like EMI. Keep the router cord away from the controller and USB, on a different circuit if you can.

I find that Easel can be a bit painful if you hit a hard limit. It will jog the machine 1mm and if there is a limit still triggered it requires another power off/on cycle. Where with UGS I can just hit soft reset and unlock and get the machine rehomed. It seems $G has no particular effect in Easel.

I guess I’m just frustrated with the machine right now, some frustration is surely due to my being a novice.

In a perfect world I could simply use Easel all the time, but have found it’s a but glitchy sometimes. I had a carving that I ran three times in Easel and simply wouldn’t cut the last portion. It was a simple text carving, quite large in size and the first letter just would not carve. I exported it and ran it through UGS and worked fine.

$G just returns your gcode modal states. Maybe you are trying to kill the alarm lock? That’s a $X.

It gets easier. Try messing with it when you’re not recovering from a crash while carving a long project. Drive it to it’s limits intentionally (you won’t hurt it) to see what happens, how to get it back under control. Run test projects in different areas. Preview gcode with a simulator. Try manual commands. Many things will go wrong…try to get experience with that before you have the end grain inlay with 16 glue ups on the machine. The machine will generally only do what you’ve told it to. It can’t recover from mistakes on its own. Do yourself a favor and try CNCjs as a sender. You’ll learn what’s going on faster.
Keep at it! Ask questions. People here are helpful. @RussellCrawford will probably design all of your family’s Christmas gifts for you!
Good luck!



I do use $X and find in Easel that it immediately locks up again if limit is still triggered. I had to set my pullback to 2mm so one jog doesn’t necessarily clear the alarm. After I jog and hard limit triggers again machine won’t unlock in Easel without a power off and back on.

Where with UGS I hit soft reset which is a $G from what I see in the console and then unlock and it will jog where ever I like.

I’m getting to a point where crashes are only being caused by a piece of material getting jammed when cutting all the way through, no matter how hard I try to ensure everything will stay stuck down with wood turners tape once in a while I get a bit that comes free and messes up the positioning.

Will definitely have a look and CNCjs, thanks for the tip!


Ugs just send that after the reset… Has nothing to do with clearing alarms.

Try super glue and painters tape.

Ok, so that leads me to the next question is there a command that can be entered in Easel to do a soft reset as opposed to having to cycle the power?

In Easel? I don’t think so, unless you modify the grbl source (wouldn’t be much to it if you’re familiar with that sort of thing).

Lol… well I’ll have to give that button a whirl… I thought it was to stop a program that is running such as the “X” in the top corner of Easel when machine is milling.

1 Like