Fusion 360 post configuration for picsender

Hi all, I am new to using picsender, (let’s be honest I am new to xcarve altogether). Does anyone know which post configuration I should use when creating gcode for picsender?

I am going to try: grbl.cps - Generic Grbl

Alright so here is where I am at.

  1. Picsender works to control the xcarve.
  2. below are the first 2 screen shots when I start the program

  1. the next 2 pics are my settings

  1. I load @CharleyThomas zeroing code and it of course runs flawlessly. the next 2 pics are the code loaded then the screen after it has run.

  1. I try to do a text carve, just carving out a 3x3x0.25 square of a block of wood, expect it to look like this when I am done

  1. I used fusion360 to draw it up and selected grbl.cps - Generic Grbl as post processor. Here is the Gcode file

3x3x0.25 carving.nc (7.0 KB)

  1. I load the gcode, the next 2 pics give the first 20+ lines of code

  1. immidiate error as soon as I send my code before anything happens. here is the error

If anyone has any advice on what I need to do differently, it would be greatly appreciated. @picengravertoo @CharleyThomas I am looking over at you 2…

I think it may have to do with the post processor I am selecting in fusion360 to generate the gcode, but i really don’t know what I am talking about.

Any help or advice is greatly appreciated!

Unless you are carving a raster image, you should check the “Vector Gcode” box.

Be careful using that post processor as it has included a G28 command, which, if set up properly, is ok. If not set up properly it can be a disaster.

Error 1 indicates grbl was expecting a command letter and the letter it got was not valid (most likely the % sign at the beginning).

I don’t use Fusion 360, but you might want to try the post processor talked about in this thread:


I agree with @LarryM


Thank you @LarryM I will read the article and check the vector Gcode. I won’t have time till 08.21.17 to get back into this, but will definitely let you know how everything works out. Advice and help is greatly appreciated.

@LarryM thank you so much for your response, now if only I was smart enough to know what to do with it! Here is what I have done.

  1. I followed the link you provided.

  2. I opened the f360-easel.cps file

  3. once I opened the file, I selected ‘RAW’ and copied everything to notepad and saved it for post processor in my fusion360. I then generated gcode using that .cps file. below is the gcode that I produced.

test1-f360-picsender.nc (13.3 KB)

I am going to try and run this gcode when I get home tonight. Unless you look at what I have done and I am way off. Again, all help and advice is greatly appreciated!

I can only comment on the G-code created.

Some people have experienced problems with the T1M6 line, I would take it out. It doesn’t do any good with grbl and could cause issues.

Since $30=1 and $31=0 the S5000M3 is plenty to cause a full on PWM signal to start the router if you use a relay for that purpose.

There is an M8 command which is “coolant on”. If you don’t have anything hooked to the “coolant output” pin then it is harmless. If you do have something connected through a relay it will turn on.

There isn’t any code at the end to shut things down, but that shouldn’t affect the carve.

I would recommend that you establish Work Zero well above your material and do an “air” cut just to see if the machine acts like you expect it to.

Since the G-code doesn’t have any ending I would do a soft reset between the “air” cut and the real cut just to reset things to normal before doing the real cut.

If that works ok, then establish your correct Work Zero and try the carve.

1 Like

@LarryM I didn’t read your response until after I tried my air cut. I tried the code as it was and received an error. I then deleted both the T1M6 line and the S5000M3 line, since I run my router manually. After I deleted those 2 lines the air cut seemed to run perfectly. Below is code I ended up with.
test3-f360-picsender.txt (13.3 KB)

I won’t be able to do any real work until next week unfortunately because of work, but after the air cut, I feel pretty confident things will go smoothly.

I cannot stress enough how helpful you have been, I don’t think I ever would have come across this information without your help, it is greatly appreciated!

You’re most welcome. Hope it works out.

Since you have to manually adjust the file, go ahead and put an M30 command at the end of the file. That will close out the job and cause grbl to return the modal commands to a known state.

@LarryM - So I am back and am so close to victory that I tried to cut real wood with my gcode and upon sending the code, my machine sped straight to the first cut position without raising up, gouging my wood. No worries, I am only using scrap wood, but I cannot figure out what to do. I did find another post talking about this and there were some suggestions:

  1. add line G0 Z0.5 which would raise my bit a half inch before starting
  2. after zeroing my bit, raise it manually before sending
  3. extensive talk about G28, which I don’t fully understand yet.

I have attached my gcode that I tested, it is just the letter W, 1/4" deep. If you have any suggestions regarding how to get my machines first move to be raising the z axis a distance before moving to the first cut position, it would be greatly appreciated.
here is gcode
W.nc (95.1 KB)

As always, thanks for all the help,
Bill Lane

I think that your problems are in the design and/or setup in Fusion 360.

I would recommend that you do a project in Easel just to check out your machine and see if it can do a simple carve. Maybe just try the test carve that appears at the end of machine setup in Easel.