Fusion 360 to Carvey - Smart Clamp Origin?

Hi forum, I am really hoping you can help me, I am trying to demystify the process of CAD-CAM for some students but I’m stumped at the moment.

I am not the first person to come across the ‘Part of your design is under the Smart Clamp and cannot be carved. Move your design away from the Smart Clamp and try again’ error.

I have tried to rectify this by;
*Offsetting the cuts 1inch form the corner of the stock
*Importing the waste board into Carvey and moving the stock away from the smart clamp
*Setting the origin WHS at the top stock corner or the bottom right of the waste board.

What am I missing here? I’m happy to attach the file if anybody needs.

Please share the Fusion360 file :slight_smile:

Sure thing :slight_smile:

Test-uni-demo.f3d (737.6 KB)

Any luck? I’m clicking around to no avail.

I havent had the time to look through it properly yet :neutral_face:`

Initial browse:
Not sure if this is relevant but Carvey 1:1 -> Origin show Z pointing towards you.
Tool orientation is however defined under Setup and can be adjusted at will.
Simulation give tool/holder collision warning.

Ok! I have solved this BUT I need to solve a tool change problem. I have 2 setups for 2 tools but when I import the 2nd gcode it offsets the z. Any ideas on how to bring this back into line with the origin?

Many thanks all :smiley:
pen2.f3d (707.2 KB)

What solved your first issue btw?

What is your workflow between tool#1 and #2? How do you re-zero?
Is the new elevated Z height = the safe distance height?

Disclaimer - I dont have a Carvey.

Hi Haldor,
We set the WHS origin off the baseboard that you can see in the screen grab. I had tried this before but for reasons unknown to me it worked on the second attempt - I have been tweaking the file so might have altered something else along the way.

There is no fixed workflow between 1&2. As far as I can see my two options are:
Put a pause in for tool changing and export the g-code as one large block - this fixes the z height for all tool-paths
or fix this z height on the 2nd process and run 2 seperate files.

I would love input on this because I’m struggling to find a comprehensive guide online for the Fusion360>Carvey workflow. As far as I can tell this is a Carvey specific problem as the z height is defined before each path by the limit switch, (or hacking the g-code which is risky in our open workshop environment).

I just finished my first multi tool / multi file project with my carvey using Fusion 360 and it went very well, here is my tricks for now. I do not have a lot of experience in CNC or fusion 360 but it worked fine.
My workflow is 3D + CAM in Fusion 360 -> Export G-code for each tool -> Import in easel and run
I used the post process file from inventable, there is one from autodesk, but it does not work at all, Easel complains about some G Code it does not support.
I set the WHS origin on the top corner of my material and it works perfectly

As you can see, I have added some “wasted” material on the left so that the smart clamp is not on the way. I could have done otherwise, but my material is 2 inch wide only ( a slice of Renshape 460 ) and my model takes the full width. I plan on carving the “lost space” later on.
There is 2 tools used ( 1/8 flat and 1/16 ball ) I exported all first flat bit operations to one G code file, run it, then change tool, upload the other file and done ( I had to make a third file to fix a little design mistake )
No Gcode editing.
Carvey does its zero smart clamp dance and then carve.

There may be an other way, because I have to take the smart clamps into account when I do my CAM, and explicitly tell not to touch any surface in the “red danger smart clamp zone”, but I think this is something you have do do anyway regardless of the clamping system you use, there is a no go zone everytime.