Fusion 360 to Easel Issues

Hello all,
I am running into an issue with either Fusion or Easel (or both) are creating unnecessary paths.

As you can see in the picture, Fusion is adding approximately 0.4" of carving before it reaches the actual material. Is there any way to have Fusion start at the top of the actual material?

The second issue is when the carve starts, the tool moves to the first cut position (at the safe height) > raises about 1/2" > back to safe height > starts carving.

The carves are working out fine, but my issue comes when I am carving thicker material. This additional 1/2" height will crash the Z into the top of the carriage. In other words, reducing my Z carve height by 1/2".

Thank you in advance for your help!

I believe this is your “Ramp Height”. I usually just let Fusion do it’s own thing, so I haven’t looked into this to hard (definitely notice this behaviour). I should probably start, but who has the time!

Good luck sorting it out.

Tony, I do have the same issue that the spindle start the carving pattern without touching the material. I am using Easel only. I have to ‘‘juggle’’ with the depth or height of the spindle prior engaging the ‘‘carve’’ action. In most cases I have the wrong depth of my carve when the job is completed. I report this situation to Inventables technical support and unfortunately I do not get anyone to respond or indication what do I do wrong?? I will be alert of responses that you may get from the community.

Locate the Clearance Height tab and test with a lower value. IIRC you can also adjust values in the right tab aswell (Dont have F360 on this particular computer so can not verify)

@AlainGauthier, sounds like you have a Z-zeroing issue.

Describe your zeroing process in the Easel Software forum for better forum attention :slight_smile:

Whenever I do the post processing, the file ends up failed “name.nc.failed”

Also the assets folder listed in the Easel-provided instructions appears under fusion 360 and not on the 360 drive. I would like to ask if anyone else is having this issues or if anyone has a solution for it, I really want to get my xcarve running.


Most likely a orientation issue, check the X/Y/Z orientation in your upper right corner, Z point to the left.
Are you able to run the simulation okay?

I had in fact forgotten to adjust that, but it still ends up in a failed file when I adjust it.

May your post fail because you set your axes with Tool Orientation? This is a rotational axis setting, and should be ignored for a normal 3-axis machine. The Work Coordinate System (WCS) should be aligned in your Setup.

It’s also a good idea to select the Model in your Setup if you havent done so already.

Have you tried a single, simple shape to test? Do the simulation work okay if played?

1 Like

In order to change ramp height you need to go to the Linking page under your specific tool path properties and adjust Ramp Clearance Height. RightClick the tool setup, Edit, Linking and set Ramp Clearing Height to your desired level.


Yes! That was it. Thank you Haldor!

1 Like

The second issue that I am having is the Z axis raising the cutter about 1/2" before plunging into the material. Is there a way to stop this move from happening?
Looking at the G Code, Line 8. I believe this is telling the machine to go to the first X/Y starting point and then RISE 0.5394". Is that correct?
If so, why would it need to do that?
I have played around with the safe distance under linking, and it does change this Z number. But even with the safe distance at .001, the G code has it rising .2".

Check pane Heights and value Clearance Height, ref. image attachment.

F360 have a separate pane for safety distances while positioning (G0) it can have different distances for anything related to actual carving motion (G1-G2). Do this solve that for you?

I have an issue I dont seem to get around, working from F360 and using Easel as sender:

In F360 I seem to get the model and machining operations as intended, exporting an Easel compatible .NC-file is also okay. However, in the Easel preview the imported NC-code set work zero (0,0,0) always in the middle/center top surface of the carved object. In F360 the lower left part of the model it is usually at 0,0,0 and I have played with tool orientation settings in F360 to no avail. What am I missing?

The workflow I intend to establish is having a fixed reference point, outside the modelled / to be carved material so I can easily carve multi face parts like image show.

Example of code header:

When you create a new setup in CAM mode, are you moving the X/Y/Z zero point to the bottom left/top corner of your mode (see pic)


1 Like

Bingo, thank you!