Fusion Gcode import Troubleshooting

I’m new to X-carve here, so thanks for the help upfront. When exporting my (gcode) .nc file from Fusion 360 and importing the gcode into easel, my carve is offset from the material. In fusion my simulated cut looks great and is lined up with the center of the material. I’ll include a picture of what easel is importing. In my fusion cam setup I have my Work Coordinate System set to the bottom left of the material with the Z axis on the top of the material. Not sure how to go about getting easel to center my cut. Also I am using the Fusion360.cps from easel when exporting my gcode.

Thanks for any advice or tips!!!

46 PM

That box in Easel represents the extents of your gcode. It does not represent your stock.

It looks like you need to move the origin stock point to be the center of the stock instead of the lower left.

Thanks for the super quick replies! I’ll try that right now and report back. Thanks!

That was the issue. Last question for now, when I start my carve do I still set my work home to the lower left of the material or the center of the stock?


What was the issue?

Wherever you set it in Fusion.

1 Like

The Issue that was resolved I think was moving the origin stock point to the center of stock in Fusion fixed it being off centered in easel. Now I just need to make sure homing my X-carve to the center of my material will cut where i expect it to. I think I will do a test cut in the air just to see the positioning of the cutting tool first.

@TylerCrowder That will work perfectly fine, but I don’t think there was an issue in the first place. Like I commented earlier, that box in Easel does NOT represent your stock. It represents the max and min for the XYZ travel. The same is true when you set your WCS origin to the center of your stock. There is no way Easel would know the dimensions of your stock.
How big is your stock? (I’m guessing about 2.5" square)

stock is 1.5 x 1.5 x 1 inch

I must not have understood that the box doesn’t represent the stock. Makes sense that easel would have no idea what the stock is. It just got feed gcode so it’s just looking at coordinates.

On my first test carve (in the air/no bit) and I had my WCS set to the “traditional” home on the lower left, it seemed that the carve was starting way outside where I would expect it to. But when centered it did the cut as expected.

Thanks for your input and knowledge!!

Is that what you set in Fusion?
I understand that you’re getting your desired result by setting zero in center, but it should work either way.

Yes the stock in Fusion should be set correctly. I’ll double check it. That could be why the code seems offset though. I’m going to try another test cut today on some scrape with the WCS set to the traditional lower left. It much easier to home to the lower left then finding the center of the material.

Thanks for you help!

My Stock dimensions in Fusion was different then my physical stock dimensions. Thats why I was getting the “offset”. I forgot I decided to change the dimension of the stock and never changed it Fusion. Thanks for helping a novice!

1 Like

Happy to help. I appreciate when I see someone want to truly understand what they’re doing.

1 Like