Inventables Community Forum

G-Code to Plane large Surface area

X Carve 1000 using a 1/2 inch straight cut normal router bit.
note: May buy a 1 inch surface cutter later.

So I am playing with manual use of G Code and so far have figured out how to set my feed rate, and move my cutter in the direction I want it to go. I plan to have the height set, and just want to move the head in X and Y axis as I am surfacing the wood.

I home my machine prior to each cutting project. And in this case, I move the head to the start of the material and set the cutting height in prep. I am trying to create a file to move my cutting head relative to its current location in a square by creating a .nc file with the following

G1 F250
G91 Y100
G91 X100
G91 Y-100
G91 X-100

When I import the code, I get an syntax error on line 2.

I can do this with the keyboard and the jog button, but something this repetitive over a 2ft by 2ft surface has no justified reason to be done manually. Which got me started down this path of creating a file to import.

What am I doing wrong? I am not using absolute locations and starting from the home point of X0 Y0 Z0.

Thanks,
John

Where do you see the “syntax” error?

G91 is modal. You don’t need it on every line, but it shouldn’t be an issue anyway.

G91
G1 F250
Y100
X100
Y-100
X-100

I enjoy gcode as much as the next guy, but is there a reason you’re doing this by hand? The example you gave would just follow a square… What about everything inside that square?

The example is just my attempt to understand how to right a file.

I am building a head board and using my CNC to surface 1 side of my lumber so its flat. I have placed six 2ft 2x4 lumber on my cnc and I need to run a 1/2 router bit over it to get a even surface so I can then run the lumber thru my thickness planer to get usable lumber.

My Y movements are 630 and my X movements are 10
After playing with it some, I have updated my feed rate

G1 F500
G91
Y630
X10
Y-630
X10
Y630
X10
Y-630

And I keep typing this in the console until I have moved down over 24 inches where each pass is about 25 inches long to ensure I get full coverage.

I have noticed when I run the above code drawing a square, it changes my relative G91 setting to absolute g90 and instead of moving 100 units, goes to absolute value 100

What about writing first lines to set current location as 0/0/0? And then use G90 with absolute values and have it move the necessary units?

The other thing is I am working in MM with G21 and not INCHES with G20 at the beginning of my code.

Thanks,
John

And just to further explain, the 2x4 lumber is not store bought. Its dried rough cut from fallen trees. Oak and Cherry.

That shouldn’t happen.

Sure. Add a G92 X0Y0 for a temporary zero.
If you’re using the same zero, I don’t see a point.

Some other options:

  1. Make a rectangular pocket and generate gcode.
  2. Use software that has a facing toolpath built in.
  3. Use something like this.

Ok, I really like that online G Code generator you provided. Is it safe to assume its working in mm and not inches?

The other thing I dont understand is the reason for this question…
The center of coordinates is in a point:

Meanwhile I am going to try adding G92 X0Y0 to the beginning of my code. Then writing the rest of the code.

The only reason I am doing this is the fact that I can not enter custom bits in Easel with out purchasing PRO. In the 2 yrs I have owned this thing, I have about 16 hrs on it. Just not enough to warrant purchasing the pro version.

Thanks,
John

This is not making any sense at all.

I home my machine, and as seen in Machine Inspector show X,Y coordinates in the neg numbers for both when I would expect to see 0,0

I Jog my machine 4 inches along the X and 4 inches along the Y axis and in the g code console type G92 X0Y0.

My nc files has the following and works (kind of)
G21
G1 F500
Y100
X100
Y-100
X-100

But whats weird is that when I run the code, the head moves about 4 inch up Y axis, Moves about the same on the X. BUT when it comes back down Y with a -#, it shoots beyond the point where it started and hits the hard limit of the machine. This indicates that it move over 8 inches. 100mm is only 3.9 inch.

How do I set 0,0 in my nc file?

When I started my nc file with G92 X0Y0, easel responded with a syntax error again and failed to import the file. Once I removed that line, it opened up fine.

Machine coordinates or work? Perfectly normal that they might be negative… Depends on your work zero for work and your grbl config for machine.

You’re moving TO Y100 then TO Y-100… That’s a difference of 200. Remember, you’re using absolute coordinates now.

Easel might have some checks that won’t allow certain words in the file… Maybe time to try something else?

back and none of that worked.

Prior to shutting down the cnc, I home it to make sure its correctly parked.

Following a cold boot of the cnc and opening the web page, go straight to machine inspector and note the machine position values as 0/0/0.

If I do nothing else and home my machine, when I look at machine inspector again I will see -779/-779/-1.002

This is messed up, all because I can not use a 1/2 in or 1 inch router bit without paying for the pro version of easel.

And all I want to do is surface a large plane of wood.

I am concerned about using any outside g code software now as how do I know the machine is calibrated correctly for it?

I rebuilt my linux machine I am using for my cnc as it needed a OS update to ubuntu 20.20. As such, I had to re add my machine and configure it. Afterwards I had to change 1 value for a acme screw direct drive from tbdcnc. Nothing else.

When I load the calibration project in the machine and cut that out, I can confirm via my digital calipers that its cutting accurately within the software.

John

This is all normal. Machine zero is, traditionally, in the back right. You are homing front left and have your max travel set at 780mm for X and Y.

Yes you can.

Unless you’re more familiar with gcode or using a gcode viewer, you’re probably best not using gcode you don’t trust.

I believe it’s unitless… Default for grbl is mm.

Yeah, that’s weirdly worded, but I think it’s giving you an option for your zero point.

Regardless, preview your gcode.

1 Like

So I stand corrected.

I removed the custom bit from tool box where i added it. Pressed Carve, and clicked the bit drop down and select other. There I added the 1/2 in bit and it took. Prior, I would have the Pro box show up on Carve and be given the option to pay for Easel Pro. And would exit out of that.

Thanks,
John

1 Like