G38.2 vs Probe in easel question

How does the Easel probe differ from G38.2? I never have any issue running the probe command in easel but when I go to machine inspector and do G38.2 it moves a small amount and then I get probe failed.

What is the exact GCODE you are sending.
G38.2 takes several arguments, like speed to probe, how far to probe before giving up (I.E. a safety feature, it wont probe forver; only a certain distance).

So I was sending just the G38.2 X0.590 F2.000, I looked at how the probe command was sending and found it uses G20 G91 G38.2 Z-0.590 F5.000 G10 L20 P0 Z1.000 G91 G20 G0 Z0.250. If i copy and paste that to machine inspector I get error: Invalid gcode ID:24. It does run if I use G20 G91 G38.2 Z-0.590 F5.000

I would like to add the retract portion but I do not see a way.

You can put the G-code in a file and send that file through Easel to do the probe operation.

G38.2 Z-0.590 F5.000
G10 L20 P0 Z1.000
G0 Z0.250

Thanks Larry, I tried that and got a error. However it worked in UGS. Who knows but it worked for calibrating my X Y and Z.

If anyone is interested I used this video as reference

What error did you get?

Line 1: G20 G91 G38.2 Y0.590 F2.000
The file contains invalid G-code syntax.

The file looks like
G20 G91 G38.2 Y0.590 F2.000
G10 L20 P0 Y1.000 G91
G20 G0 Y-0.250

Put the G-code in the file like the text I gave you above. One G code operation per line and see if that works.

No. I just thought it might work as Easel is pretty picky about many things. The one time I tried multiple G-code commands on the same line in Machine Inspector it wouldn’t do it, so I thought single lines in a file might be more successful.

Joe can probe successfully in Easel, he was just trying to use G38.2 in Machine Inspector for some reason.

My goal was to used the probe command with 123 blocks to calibrate x y z. I ended up making the file and just using ugs to run it