GCode Issue?

If any GCode gurus have a moment, I’d appreciate a little help. I’m having an issue, which at this stage I’m assuming is either a Post Processor issue or is a GCode issue (or both).

When creating a simple toolpath (using the latest version of VCarve Pro & sent via stable build of UGS), everything works as normal, right up until I try to run the toolpath. All that happens is the machine moves diagonally by about an inch then reports it’s finished.

What’s odd however is that if I run a toolpath that was created using the same apps & settings, it’ll run perfectly well…

I’ve updated my Post Processor (J-Tech Photonics “No Z” version)
I’ve tried re-creating the toolpath as a profile cut, engraving, pocket etc.
I’ve even created a new Tool (end mill) from scratch

Any assistance would be hugely appreciated - gcode file is attached.RTP.gcode (6.0 KB)

In your first 8 lines, try removing the T and Mcodes that don’t pertain to your router . I found out that these impacted my use of the X controller through the UGS. Delays, Tool change, coolant on coolant off, end of program, etc. The only ones you need are the G17 and G21 if it’s a plain old router in wood deal where you insert the bit yourself. See if that makes a difference.

This might be a dumb question but are you trying to carve this gcode or laser it? This gcode is set up as a laser project with the M lines and S suffixes.

1 Like

Apologies, it’s a toolpath for a laser job. The post processor is also (supposedly) set up so that there are no Z axis movements.

Looks fine to me. My advice would be to not use UGS.
Ran fine (simulated), with CNCjs.

1 Like

Thanks @NeilFerreri1tried it with Picsender and it ran (once), but it then everything began going awry.

Picsender began throwing up errors (didn’t note them down) and then trying UGS again simply meant it locked itself into some kind of repetitive error loop, throwing up hundreds of error dialogs and necessitating me to use task manager to kill it.

Suspect I’ll be rethinking my choice of UGS version (I kinda like, probably because I’ve used it for so long), reflashing GRBL (I’m using the version from @LarryM), java and anything else I can think of.

Not sure what’s wrong, but am at a bit of a loss with regard to the cause. Older toolpaths continued to work fine (up until UGS and Picsender played up). Been at work for 14 hours, so now’s not the time to think and fault find.

Thanks for your help nonetheless.

David, I have dry run run your file several times in succession using PicSender and my real time USB analyzer software, and see no errors in your code as far as PicSender or my grbl version (1.1g) report.

You might try adding a G90 to the start of your file (PicSender adds this automatically) to assure grbl is in absolute mode. The T1 is ignored by grbl and PicSender and serves no real purpose, so it can be left or removed.

It is possible that you have a hardware/controller problem, or your version of grbl may be corrupted somehow. The error number you are getting is an important clue to help in resolving this issue for you. Please let us know what it is.

Remember that if you choose to use the PicSender option for managing your grbl parameters, PicSender will load in the grbl parameters from the saved values on your disk drive based on the mode you have selected ( my 1.0c $32=1 and rpm 0 - 255 for laser or $32=0 for spindle)

You must leave PicSender with the spindle mode selected (if your next job is a spindle job) to use any other sender as PicSender is the only program that automatically switches the grbl parameters on the controller.

You can turn off grbl parameter management on the “GRBL” option page by checking the appropriate control.

You can damage your mills/bits if you run a spindle job with laser mode selected.

I ran some tests on your G-code file with machine movement defeated.

PicSender - everything ran fine

UGCS 1.0.9 everything ran fine

UGCS 2.0 (potential stable build candidate) the program went nuts. Continuous errors. Killed with Task Manager.

Ran PicSender again - everything ran fine

Ran UGCS 1.0.9 everything ran fine

This was running on my 1.0c version of grbl.


Thanks Larry,
After further thought, I’d pretty much come to the conclusion that my next option would be to go back to an earlier version of UGS (or to use something else). I’ll do that and see what happens.

Thanks also for the heads up about Picsender. I’d actually discovered this accidentally without damaging anything - something of a novelty for me…

Thanks to everyone for your time, suggestions and willingness to help. This is what makes this forum so useful. It is very much appreciated.



I don’t disagree with your suggestion. I’ve had a couple of issues now with UGS - I guess continuing to use it is (or arguably was) easier than changing. I’m also a male-of-a-certain-age - a demographic not renown for its acceptance to change or alternate opinions…

More seriously, yes, I suspect I will change and a quick read of the Wiki page for CNCjs looks interesting. When I get some time I’ll look into it a little deeper.

As a user, are there any significant feature that prompted you to use this over some of the other similar tools?


I took a look at this and only got part of the way through how to setup node.js

Reminds me of the hassle of building a Unix kernel.

Maybe I’m missing something.

It always works.

It’s actively developed, the macros are pretty powerful, it always works, and I like the GUI. I was originally drawn to it because I wanted to run a machine remotely, but the desktop app is great. I’ve tried most of the free senders. UGS is very popular, but I think there are version issues and I’ve seen a lot of issues from others that have been resolved by using something else. I have nothing to do with CNCjs…I just like it. I like bCNC as well, but it is ugly and cumbersome.

1 Like

If you send me the actual file and not just the Gcode I could most likely help you resolve the issue. It is a post processor issue. I have run into this issue myself a few times

At this point there are many people making multiple suggestions some of which conflict and some don’t. Most productive path at this point would be to pick some one and go off in a Private Message one on one debug session. Pick a time when both parties have a block of time to spend on it and see what comes out of that session.

Anyway, good luck with your investigation and post the solution here for all to benefit

1 Like

Thanks Larry will do ASAP (travelling).

Apologies for the slow reply and many thanks to those who provided suggestions.

I rolled back to an earlier version of UGS and things worked as normal. I feel like a dolt for not trying that before coming here, but maybe my error may assist someone else.

Don’t know where I’d be without this as my brains trust…

Merry Christmas to all.