Gcode stall

Hey guys, wondering if I’m doing something wrong and if you might be able to help.

Every now and then UGS will process a file I’ve used previously that worked a bit different and just go AWOL, either plunging and staying there, or just walking the end mill straight through the face of my material. Yesterday I ran a file that cut 5 identical pockets out, 1 follow path, and a profile. I was using spotted gum so it took about 2-3hours with the 400W spindle + 3.17 end mill. I ran the same file today twice on the same material and it stalled both times.

The first job ran the 5 pockets and follow path fine, then just stopped moving half way through the profile operation. Not too bad, I can finish off on the band saw.

The second job dragged the bit between the first 2 pockets, and then froze on the third pocket. I had to reset UGS and re-zero etc.

I’ve had the same issues if exporting gcode from Makercam or Easel and running through UGS. Fusion 360 unfortunately keeps becoming unresponsive on my macs, they’re apparently aware of this.

What I’m asking is:

  1. Is there a better way that doesn’t send you broke?
  2. Is this something like a dropped line of gcode from streaming grbl to arduino? If so is there a way to fix?

I am no expert, but after the wonky behavior of UGS I have switched to bCNC.

it takes a little bit of setup to get the needed python modules installed to run it, but this software seems pretty solid so far. It is python so therefore cross-platform. I have only played with it on PC.

I use Chilipeppr and it has the abilty to run a simulation of your job at 100x normal speed so you can see what is going to happen and erros can be spotted.

I am no expert on UGS but because my machine is out of WiFi range I cannot use Easel or Chilipeppr, so I have to use UGS. While I was searching the web for help, I found that you can easily increase the memory size of UGS.

You have to edit the bat file, I increased the memory use to 1024mb, just right click the bat file and edit it with notepad from 500mb to 1024 or if you have plenty of memory to 2048mb.

I only started up my machine 2 days ago but everything works fine for me.
BTW I copy and use the gcode files locally to the machine from my USB pen-drive.

regards Neal

I was having problems with UGS.
(It would not turn off the spindle at the end of a cut. it would just sit their, paused until I canceled it. After that it would act, odd. Restarting UGS fixed it.)
I wound up updating the version of GRBL on my GShiled (That was a 2 day adventure in frustration) and using a newer version of UGS.
After that it has been stable.

Check your USB cable as well. Some people who have been having intermittent problems (file works one day stalls mid-print the next) fixed it with a new USB cable and/or adding a self powered USB hub to the setup. (Their laptops not being able to send enough current over the longer USB)

Any chance your motors/GRBL shield is entering Thermal Overload (or whatever it’s called)? That would cause your job to stall. Fixed by adjusting potentiometers on GShield.

Thanks for the tip Justin, yep that’s pretty much what it was I think. The temperature here this week has been bloody hot, and I hadn’t had the problem before. Trimming the drivers and increasing the airflow to them seems to have fixed it!

Awesome! Everyone was talking software so I thought I might have completely missed the point. Super glad you got it working!