Generating Paths

How long does it normally take to generate paths in easel. I am trying to cut a design I did but it is taking forever to generate the paths. I opened another design from the projects section http://easel.inventables.com/projects/moe0u1wRlelzQA7A21P4KQ
and tried it and it is the same way. So I was just curious as to how long this will take and will it be that way every time I run this item. Thanks.

I just tried opening that same file and there’s no movement on generating toolpaths. I just saw on another thread someone else had the same issue. It appears to be a bug/glitch in Easel.

@rodovich I know you posted a little while ago that the issue should have been fixed, but I think the bug is still there.

I’m hoping it’s just a momentary glitch with easel. I did another small design this morning and it worked fine and still does.

Same here with me too. I/my wife sells projects for a small facebook business. The only thing I’ve used thus far is Easel as far as the X-carve goes, so its my only option for now. If Easel doesn’t work, neither do I. So this ‘bug’ is costing me. Hopefully its soon fixed. Also, with work etc., I’m limited to when I can work on my projects, and I’m backed up as is. This is not good. I guess I shouldn’t have all my eggs in the Easel basket.

Hi @StuartCampbell, I’m sorry for the trouble. It looks like an error is occurring when generating the toolpaths. I’m looking into the cause & will update you soon.

Hi @StuartCampbell, this bug is fixed & toolpaths will generate for this project again. (On my computer it takes about two seconds.)

@TomP if any of your projects are still unable to generate toolpaths, please post or message me the link.

Thanks, mine is working now. I will definitely be learning other software so I am not dependent on easel but it’s great to have.

Im a total newbie. I too have just encountered the same problem.
I’ve successfully cut a couple of test pieces which were drawn up in Easel. Now I’ve noticed that when attempting to draw up 9 lines of text in whatever font… That it either crashes with Chrome when generating tool paths (Takes a long time to generate) Or if i click on Carve & home the machine, switch on the spindle (Logic) then it generates paths… Locks up when generating & leaves the spindle powered on… Any tips?

Actually, I think that’s an unrelated issue. It’s very expensive to generate toolpaths for large amounts of text & can overwhelm the browser. Improving Easel’s performance with complex projects is one of our top priorities right now. In the meantime, you’ll probably have better luck carving just a few lines of text at a time.

Out of curiosity, do you have the text as filled shapes or outlines?

I have found that if your bit is to big it won’t generate the tool paths. At least that’s been my experience.

I to am having the same problem last year I would cut a project with no problem I’d say August then I took some time off and now I’m back trying to do the same cut the system did make me upgrade before I could do anything (being that I hadn’t used it since August) I loaded the same file went to carve and the generating path just hangs there after 25 minutes I had to force a quit. Some said that maybe I should do something with my memory but I have 8GB on my system and Easel is a cloud base program so what would memory have to do with it. I have tried this on 3 other computer and they do the same thing. I did load the file into Aspire and did a path and it did it in like 30 seconds. I would use the g-code in aspire but I still need to learn more to make sure it’s correct. Easel was always easy now it’s not. Any idea’s.

I am having the same problem, yesterday i had no issue with making tool paths. Today, i start it up and it makes me do an update, now tool paths just sit there. I even let it sit for over a hour and still did not move. How do we fix this?

Im not sure if you get sent a message when we post. But my xcarve made me do a update, now when generating tool paths it just sits there. How do i fix that?

Hi @MichaelBrooks, can you post a link to the project you’re having problems with?