Getting toolpaths from V-Carve Pro to my X-Carve

Hi folks,
I successfully done the test carve and a couple of dinosaur skeletons using Easel, but I found Easel to be hideously slow. So I’m diving into V-Carve Pro a bit earlier than I anticipated.

I’ve got a design worked out in V-Carve Pro and have saved the toolpaths.
So I have 2 toolpaths that use the same bit, the first is a shallow decorative pattern and the second is a cutout pattern.

But thats where I’m stuck, I have no idea how to get the toolpaths to my machine and what steps to follow to get the machine to execute the 2 toolpaths.

I’d love some advice at this stage.

Ifyou want to joint two tool paths on Vcarve, you can click to checkmark save all visible tool path option on upper window first then click each tool path you want to save. To sent saved tool path, you can use Gcode sender or chilipeppr. While saving same bit tool path, the first one you want to run must be on top of other on the list.

you need to have a program to send gcode to your machine

most people either use Universal Gcode Sender or Chillipeppr

i prefer UGS but chillipeppr has some neat features

Thanks Alan and BadWolf,
You both taught me something.
I figured I was missing a piece of the puzzle :smile:
I’m going to give UGS a go. From what I can see Chillipepper is another browser based app lie Easel.
I’m not sure if it’s a bandwidth issue or something else, but I usually find browser based apps are a problem.

1 Like

yes thats correct chillipepper is browser based (and the main reason i dont use it)

id suggest getting version 2.0 nightly build for UGS. it seems to be the most stable. i had a lot of issues with 1.08 but havent had any with 2.0. the web page is a little confusing on where to click to download so if you have any problems just give a shout

Another step to the puzzle will be getting the tool paths out of V-Carve in a way that UGS will send and your X-Carve will like.

If it isn’t already installed, you will need to install the X-Carve post processor for Inch and Millimeter, and then for each tool path you will need to save them out using that post processor. Doing this, will give you some “.gcode” files that you can send to your X-Carve with UGS.

If you need more details on how this is done, I can post some links and screenshots…

1 Like

Brendan, having just gone through this process myself and finally got everything running well. I would make these comments which I hope you find helpful.
As you have found with Easel, web based processes have their limitations.
Both Universal G Code Sender (UGCS) and Chiilipepper require you to download another program for them to work
In the case of UGCS you need to load Java first, (available free to download).
UGCS defaults to inches when you open it, if you happen to be working in metric BE CAREFUL to check the mm option. The difference between 5 inches and 5mm can leave a very ugly hole in your wasteboard and a frightening sound to go with it.
I tried both programs and personally I found UGCS the easier to use. I am not claiming “better”, just easier.
Good luck

Hi guys,
Thanks for your help so far, it has been enlightening.
But the saga continues…
I now seem to be having problems getting UGS to recognise the bottom left corner of my job as my zero position.
I have UGS 2 nightly build installed and it is talking to my x-carve.
I successfully loaded a toolpath generated in V-carve with the X-carve post processor and sent it to the X-carve from UGS.
I jogged the machine to the bottom left of my job and clicked the “Reset Zero” button in UGS.
It’s my understanding that this manually sets the zero position to where I have placed the spindle.
The console in UGS stated that XYZ co-ords had been set to zero.
I then sent the job to the X-carve successfully.
Unfortunately the zero position is still wrong. It started the carving in the bottom left corner of my material, but the part of the design it started carving is actually a bit right of centre of the entire design.
I went back to V-carve and checked the job setup and noticed in the XY datum position that the check box for “Use Offset” is checked with the following co-ords X: -318.591 and Y: -125.218…
I’m guessing this is my problem…
When I uncheck the Use Offset option, all my vectors move proportionally moved down and left and I cannot get them to line up on the job depiction in V-carve.
A pic here would help but I haven’t quite figured out how to do that yet :smiley:

So I guess my question is; am I on the right track with what the problem is here, and does anyone know how to correct it?

Kind Regards

You don’t have to tell the machine zero to UGS, If your home switches working, let UGS find the X and Y zero coordinates for you by clicking $H button. Don’t pay attention to numbers first. Even your spindle will be all the way up. Just a safe side, after Homing sequence is over, you can click Rest X-Reset Y-Reset Z buttons. that gives you chance to jog it to work piece and do your zero assignment for XY and Z manually.Re-read my post.