Ghost in my machine...? (BUSTED)

When I home the machine it’s fine, then about 3 seconds later it shoots to the right and then randomly goes where it wants. I check connections, everythings tight, normal. I shut everything down, restart computer, try to home the machine under the drop down menu and no response. So I try to carve, try to home, says wait a minute, no response. Try to carve without homing and instantly the machine goes crazy, I push panic button, now here I am. Any ideas?

Is there anything helpful in the Log information? It slows down the machine, but you may want to open it and keep an eye on it.

Check the controller for errant bits of metal or shorts?

Have you loaded any commands for the machine to execute at startup?

I’m assuming you mean the machine inspector?

Nothing looks like it has shorted.

And if any commands have been loaded for startup I’m unaware. Anyway to reset?

When you are in the Machine Inspector (the place where you can change grbl parameters)

Enter the command


You should get the following response if you don’t have any grbl commands established


Says, error: Alarm Lock
I’m assuming this is not good…

That’s ok. It should be that way since you haven’t homed the machine yet.

Go ahead and do the $N, it will work with the alarm set.

Still nothing but alarm lock…

Ok, Easel must be blocking it.

Do you know how to use the Arduino IDE, UGCS (Universal G-code Sender), PicSender or any other serial terminal program like PUTTY?

Literally just got finished downloading UGCS, not sure exactly what I’m doing but I’m this far and getting this message when typing the $N command

Your baud rate is wrong…change it to 115200.

So is that a no to xloader then? After changing baud rate I’ve connected to UGCS but still getting the same , error:alarm lock

I am not sure what issue you are having, but if you have homing enabled then the alarm is normal when it first boots up/connects to UGS.

EDIT…if it connects properly, xloader is probably not necessary.

You should be able to issue the $$ command in grbl and have it print out its parameters. Do that and post them here.

No to Xloader at this point.

I get nothing like that, just this repeatedly.

When you open grbl with UGCS what version # is printed out?

Make sure that verbose output is not checked.

version of grbl not UGCS

**** Connected to COM17 @ 115200 baud ****

Grbl 1.0c [’$’ for help]
modified by Larry Mayberry
[’$H’|’$X’ to unlock]

verbose not checked
**** Connected to /dev/tty.usbserial-640 @ 115200 baud ****

Grbl 1.0c [’$’ for help]
[’$H’|’$X’ to unlock]
error: Alarm lock
error: Alarm lock
error: Alarm lock
error: Alarm lock

Is “Show Verbose Output” checked in the middle of the UGCS window? If so uncheck it.

no it is not

Ok, we’ll do it the hard way.

$X will clear the alarm
$$ will display the parameters