Goko User friendly CNC control software

I have not used it so I do not know anything about it but it was posted on the Shapeoko forum so I thought I would share. It is multi-platform friendly to boot!

3 Likes

Thanks a lot for reposting :slight_smile:
I’m the author of Goko.

Feel free to ask any question, report bug or request new features. It’s always nice to have feedback

2 Likes

Installed, but I get an error on launch…

Same here. :grimacing:

ditto. What OS does it run best in Psyko? 32 or 64 bit? I tries on Win7 64

@TonyNo @AlanDavis
To chose between 32 or 64bits is not actually related to the OS but to the installed Java Virtual Machine. The JVM exists both in 32 and 64bits and both can be installed on the same OS.

This error usually happens when you try to run the 64bits version of Goko but you have a 32bits JVM.

To check the used version for running Goko, simply run the java -version command Windows command prompt

It should display something like this (for 64bits JVM at least)

java version "1.8.0_77" Java(TM) SE Runtime Environment (build 1.8.0_77-b03) Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

You can also run the following commands, and java will tell you if it can handle 32 or 64 bits apps :
java -d32 -version and/or java -d64 -version

Outputs the following :

C:\>java -d32 -version
Error: This Java instance does not support a 32-bit JVM.
Please install the desired version.
C:\>java -d64 -version
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

@JonGenow it should run fine on both 32 and 64bits. I mainly tested it on Windows since I don’t have acces to Mac or Unix systems yet.

1 Like

Maybe add that info to the download buttons. :wink:

So that was the issue ? Did you manage to run it on your computer ?
I’ll make it visible in the download section somehow.

Started up OK for me on Linux (Ubuntu 16.04)

1 Like

Details about version detection were added in the version dialog on goko.fr

Details were also included in online documentation and in tutorial Installation

1 Like

I loaded some gcode, but it looks like it’s not recognizing arcs?

@TonyNo
Strange, I had no issue with arcs.

Could you please provide the GCode file ? Simplest way is to copy/paste it into Github Gist https://gist.github.com/ and post the link here

Yes that was it. It is working. I like screen look. I hope this gives better chance to get rid of UGS. I have to master it. So far didn’t see macro option for touch plate.

@TonyNo

Oops, lookis like G02 and G03 are not handled correctly. Only G2 and G3 work.
I’ll post an hotfix asap. You’ll get it through automatic update
Opened an issue to keep log : https://github.com/cncgoko/Goko/issues/30

@AlanDavis
This feature is not included yet. I plan on adding a macro system in the next release (hopefully soon). By touchplate macro, you mean automatic zero detection and call to G28.3 ?

3 Likes

Supoort for macros (user defined) would be great.

1 Like

No biggy, we’ll wait. Thanks for joining this forum. Looks like you’ll bring godies. :relieved:

@TonyNo

Hotfix released. You should be able to get it through auto-update.

There end up being a window that you need to click in, but it’s not in front, so you have to guess and hit Enter to proceed.

I then got this…

Maybe a slash problem?

Update. After that, launching throws this…

I doubt this is a slash issue, because all these calls are Java’s business. Goko does not invoke the jvm.dll itself.

It’s strange because it looks exactly the same as the first issue you mentionned. Running a 64bit Goko with a 32bit JVM.

How did you solve your previous issue ? Installing another Java version ? Using another goko version ?

Can you please provide :

  • OS version
  • JVM version (type c:\ProgramData\Oracle\Java\javapath\java.exe -version in windows shell)

Thanks,