Goko User friendly CNC control software

I installed the 32-bit version to match my Java.

Win 8.1

The arguments in the error message indicates that your trying to launch a 64bit version of Goko (launcher library ends with x86_64).

I’ll try and install the 32bit version and perform an update to see if I can reproduce.

I first tried the 64-bit version, then installed the 32-bit version over it. That was fine until I tired the update. I’m deleting everything now and reinstalling…

It’s probably not a good idea to install “over it” (as I understand, you didn’t delete the 64bit files, right ?).

If 64bit config files have different names, they won’t get overwritten/deleted when installing new files. The framework behind Goko might still think it’s running 64bit. But that’s only a guess…

That worked, but I now get this error on start…

The error you show is already fixed in the develop branch. It will be available at next release. I think it’s not 100% reproductible and should not be a problem. It might affect the Windows > View menu (probably being empty when the error shows).

For the grid, it was switched to inches, but the grid settings also got transformed from mm to in. So the major spacing changed from 10mm to 0.394in. You can change that in the Grid preferences. I might add the unit somewhere in the viewer as well as graduation for each major line of the grid. It will probably make it easier to understand. Or maybe you have something in mind ? I’m not used to imperial units, so what’s the common divisions ? 1in and 1/4 or 1/8 in ?

Anyway, thanks for your feedback and patience :slight_smile:

Edit: your message was edited, removing the grid issue, but I keep my response as a log/open question.

Thanks.

I didn’t notice the grid. That was about the Bounds display.

The divisions actually depend on the scale of the job. It should be flexible/adjustable. Most people here run large jobs on their 1000mm machines, but some of mine are only 1" across. :wink:

@TonyNo

Just to let you know : latest version of Goko allows you to define and use GCode macros :slight_smile: version was released few days ago.

1 Like

Hello,

Version 0.3.3 of Goko was released few hours ago :slight_smile: