Good Grief! More smashed Z switches

Move the Z axis up by hand turning the pulley until you get the Z axis switch to trip.

Get a piece of wood or other material that is the same thickness (or just a little smaller) as the gap between the moving Z axis carriage and the Z axis motor mounting plate. We will use this material to stop the machine without breaking your switch if homing doesn’t work right.

Move the Z axis off the homing switch by hand.

Make sure you remembered to change $1 to 255 and $21 to 0

Holding the block in place to protect your switch, in PicSender, press the $H button and get ready for the E-stop if the homing sequence doesn’t work.

Can I copy and paste these new values into the DO CMD?

Yes. You have to press “Do CMD” you can’t just use the enter key. After you do this display the grbl parameters to make sure it worked. Use the “Grbl Set” button.

Do you mean GRBL RESET button?

Looks like my PicSender V2.5.6 download is ready.If I get everything set with the old version, will the changes be there in the V2.5.6 version after I install it?

No, there is a gray button above the buttons for homing ($H) etc. that says “Grbl Set”. It’s a bit confusing, it doesn’t set the parameters, but it will cause them to be printed out in the message area.

I have to be away for about 1.5 hours, I’ll check back in when I return.

Got the new version installed, Went through everything we discussed. Homing worked perfect, gave the G28 and that moved to the default position, hit home and it homed again with no errors. But, I opened up Easel and tried to home from there, and the nice little chunk of Aluminum, that I made a stop out of did it’s job and prevented the switch from getting smashed, and got an Error saying there was an object in the way and that the homing failed.Next?

Back early.

Great news.

So now we know that homing is working properly and it’s Easel that is not working. I noticed that you are running the 3.1 version of Easel local.

I don’t use Easel, so when someone has an issue that I think I can help with I install Easel and then when I’m finished I uninstall it.

When I just go to Easel and it tells me I need to download the Easel Local driver I let it do it and that installs version 0.2.7 so maybe 3.1 is a test version.

You could try to uninstall 3.1 and then install 0.2.7 to see if that works, however, beyond that I can’t help with Easel.

Nice to know that you don’t have a hardware problem.

1 Like

If you are talking about the changes that we made to grbl, then yes. Those changes are stored in grbl in the X-controller.

1 Like

@LarryM Ok, so i am moving around in PS just fine (jogging) and set my G28. Works great! But, I tried to run job and I get soft limit alarms. I switched back to the current driver on Easel and it still tells me the homing failed

DOH! I forgot to zero XYZ before I send…tired,need Red Bull

Your display picture shows that you have laser mode selected.

Which version of grbl do you have loaded in now?

1.0c. I was using my laser, just gave it a test drive and worked great. Now I am going to carve something real quick…BTW, I have never used PS for carving, just laser.

Ok, remember that the grbl parameters change when you switch modes. Check them out before you carve.

The grbl parameters that you posted above don’t indicate that you have a laser specific version of grbl Have you reloaded since you posted your grbl settings?

Well I just finished a laser job and a carve. The only thing I changed was the spindle and laser button.
Is there something else i need to change?

I have no idea what’s goin on with Easel (it still hates me), but I like using PS for both.

1 Like

I have a modified version of grlb that works with the spindle and laser which will give you better performance than the standard 1.0c when you are in laser mode.

Do you have the JTech laser?

1 Like

Yup, 2.8w

You can read about it here:

1 Like

That’s awesome Larry, thanks so much for walking me through PS, I learned a lot today!