Inventables Community Forum

GRBL / Easel / Laser option

I have a 1000mm X-Carve with the 3.8w JTech Laser addon. I read the Jtech site which suggested using their custom fork of GRBL to accept S-commands without pauses, which got me reading and ultimately interested in GRBL 1.1 which supports laser mode natively. Now that Easel supports GRBL 1.1, I figured why not. I took note of my settings and uploaded GRBL 1.1, then took care to restore my settings afterwards. After uploading GRBL1.1 , M03 SXXX doesn’t seem to do anything – whether its 10 or 255. Spindle max RPM ($30=255) is set.

Additionally, it seems that with GRBL 1.1, the nightly UGS moves the steppers incredibly slowly. UGS 1.0.9 moves them normally (as does easel) but UGS 1.0.9 seems to have some quirks with GRBL 1.1. I was interested in the UGS nightly builds for better support from PicEngrave+Laser before I pick that up…

Is there a magic combo I’m missing out on?

Thanks for reading!

2017/05/09 20:10:30 - $1=255
2017/05/09 20:10:30 - $2=0
2017/05/09 20:10:30 - $3=3
2017/05/09 20:10:30 - $4=0
2017/05/09 20:10:30 - $5=0
2017/05/09 20:10:30 - $6=0
2017/05/09 20:10:30 - $10=115
2017/05/09 20:10:30 - $11=0.020
2017/05/09 20:10:30 - $12=0.002
2017/05/09 20:10:30 - $13=0
2017/05/09 20:10:30 - $20=0
2017/05/09 20:10:30 - $21=0
2017/05/09 20:10:30 - $22=1
2017/05/09 20:10:30 - $23=3
2017/05/09 20:10:30 - $24=25.000
2017/05/09 20:10:30 - $25=750.000
2017/05/09 20:10:30 - $26=250
2017/05/09 20:10:30 - $27=1.000
2017/05/09 20:10:30 - $30=255
2017/05/09 20:10:30 - $31=0
2017/05/09 20:10:30 - $32=1
2017/05/09 20:10:30 - $100=40.000
2017/05/09 20:10:30 - $101=40.000
2017/05/09 20:10:30 - $102=188.976
2017/05/09 20:10:30 - $110=8000.000
2017/05/09 20:10:30 - $111=8000.000
2017/05/09 20:10:30 - $112=500.000
2017/05/09 20:10:30 - $120=500.000
2017/05/09 20:10:30 - $121=500.000
2017/05/09 20:10:30 - $122=50.000
2017/05/09 20:10:30 - $130=790.000
2017/05/09 20:10:30 - $131=790.000
2017/05/09 20:10:30 - $132=100.000

If you don’t need the forced feed rate, etc. overrides in grbl 1.1,

this is your most integrated solution for PicEngrave:

Xcarve_JTech_grbl + PicEngrave + PicSender.

Just my (biased) personal opinion.

grbl 1.1 + PicEngrave + PicSender would be my second choice

1 Like

Check your PWM wiring to the laser controller.

Check to see if you have CW, switch selected on the laser controller.

Make sure that grbl is not in the “Alarm” state.

1 Like

Sorry I forgot to mention a few vital bits:

Originally I went with the change in FW because the first few laser passes produced smaller-than-intended images. According to the files I submitted in GCODE they should have been about 400% bigger.

PWM wiring to the controller seems to be solid, as on the JTECH0.9 GRBL I can use M03 Sx to set all variety of power from 1-255 without issue.

I’ll check on CW/switch and report back. I need to review the driver PDF.

GRBL is not in alarm as once I unlock the machine it seems to respond to movement commands as expected.

Thanks for the reply!

That’s strange.

UGCS nightly built is software in flux. It’s possible that you got a bad build. The GUI to grbl interface changed with grbl 1.1 and that’s why UGCS 1.0.9 does not work well with grbl 1.1

Do you know how to use the Arduino serial monitor?

Yes I know how to use serial programs. One of the benefits of being in IT for 13 years when it comes to hobby tinkering! :slight_smile:

I’ll read up and see what I can find.

Using the serial monitor you can learn where the problem exists in your tool chain. With the serial monitor you are talking directly to grbl without any embellishments.

Most of the sender programs do special things to make life easier, but if you don’t know what those things are the senders can mask errors.

At the lowest level (serial monitor) if the M03 Sxxx doesn’t work then you most likely have a hardware or firmware issue.

Ok so I connected via putty and issued M03 S50 directly and it said ‘OK’ but hte laser didn’t turn on. if I flash the JTECH 0.9j firmware, it turns the laser on. Doesn’t that rule out hardware / wiring? The trouble with this firmware was that I had difficultly with things being the wrong size. I suppose I’m game to correct that issue instead of trying to force the issue on GRBL 1.1, I’m just hoping I can find a solution where the entire setup (CNC router + laser) works reliably and can switch between them.

The CW switch is away from the power switch. Flipping it towards the power switch turns on the laser to full power and happily starts burnining my test wood.

Try using this version of grbl. There are a lot of people running it dual mode. The only thing it doesn’t have that 1.1 has is the forced over ride functions. This version will work with UGCS 1.0.9

https://discuss.inventables.com/t/xcarve-jtech-grbl-update-11-12-2016/28943

1 Like

Very interesting. laser fires right up. Giving this a dry run without laser to see if the dimensions of the moves are right!

Will report back, thanks!

Everything runs great! About 20% through the engrave the laser shutoff. I cancelled the engrave now not even setting CW turns the laser on… Onto the next challenge! Thanks so much for the replies helping me get this running!

If you removed power from the laser controller then you need to reset the laser controller for it to work again.

No it seems to be a loose wire inside of the laser itself. I applied a bit of pressure and re-clipped it and it seems…a bit better. Hopefully it wont jog loose again. If it does I’ll poke around on the jtech site or email them to see if its repairable.

1 Like