Grbl hasn't finished booting

I opened Universal G Code Sender and then tried to send information to machine and got a response that said…“grbl has not finished booting…”. I tried to shutdown everything and then reboot the entire system but I still get the same response. As a side bit of info, everything was working fine on one night and began this problem the next morning. I had shutdown everything that night with fresh startup the next morning. Can anyone advise my next step???

Are you connecting at 115200 baud, that is a common error for wrong baud rate.

No, I am using 9600 baud. I did not change anything from when it was working correctly, that I know of.

Use 125000, that is the correct speed.

@ErikJenkins

Typo?

1 Like

115200 is the correct speed!!!

Sorry, fingers not working!

If 9600 worked ok at 11:00 pm but not at 10:00 am the next morning what changed during the night. Sorry, that don’t make sense to me.

what version of grbl is loaded? 9600 should not have worked on any of the latest versions.

Since we don’t know exactly the steps you took, no one can say what happened the first time you tested.

There are many programs that change the baud rate on a serial port.

115200 is the correct baud rate for version 0.9 variants of grbl.

If you want to run at 9600 you can get the source code for grbl, make the appropriate changes, recompile, reflash your Arduino, and you’re all set.

I don’t know what version I have. How can I find out? I have had this Arduino about 18 months.

when you connect with UGS it shows the version.

1 Like

Use either $$ or $I command to grbl - either direct to grbl via the Arduino IDE serial monitor, or through the Machine Inspector in Easel.

If you updated from grbl 0.8 to 0.9 the baud rate increased to 115200.

grbl version 0.8 variants default to 9600 baud.

Erik, you type faster than I do. :smiley:

1 Like

Okay, I am a dummy when it comes to stuff like this. I tried $$ and got same message`, tried easel and got nowhere. I don’t know enough to use Arduino but figure I must have an older version that uses 9600 baud.

Now, can I use an upgraded version to use the higher speed and can you provide me with very specific steps to put an upgraded grbl on my Audino Uno?

There is more to just updating, a couple of pins have changed from the older version:

Pins D11 and D12 swapped

The info to update your arduino is here: https://github.com/grbl/grbl/wiki/Flashing-Grbl-to-an-Arduino

Erik, I appreciate your helping me but now we are at a point that everything is “GREEK” to me. Maybe I can describe what I’ve got and go from there.

I am using a grblshield and only have the 3 axes X,Y,Z hooked up. No limit switches and no spindle. I guess I better stick to grbl v0.8 to simplify everything.

I have printed out both listings you gave me. I’m sorry but I just don’t understand where to go or what to do about flashing. Can you give me directions that I will be able to understand?

Oh, I am on a Windows 10 computer. I am using Com3 @9600 baud.

Have you ever used the Arduino IDE?

Not that I know of.