Grbl homing switches

Hi, I’m new for CNC and GRBL 1.1f.
I’m trying to upgrade my CNC machine to get limit switches.

This is my CNC board and all the 5 limit switches (connected as NO and one z axis switch) are connected as below image.

All the 5 limit switches are working fine. But when I press the home button, it moves up along the z axis until it hits the limit switch and it tries to go up more about 5 seconds and the status goes to alarm . I was wonder why it is not stop or react when it hits the switch and why it only moves z axis even if it does not react the limit switch.

current my settings are as below
and I can communicate my board with arduino IDE (board: arduino nano, processor: ATmega328P (old))


Please help me to solve this problem…


Change $27 to 5mm ($27=5) because each home switch is triggered twice. First at Homing Seek speed ($25), then Homing Feed speed ($24). If the trigger is not released due to insufficient pull-off distance ($27) it will throw an alarm and halt.

My current setting for $27 is 5mm which is $27=5.000

My problem is when I press “HOME” it goes up for Z axis and ignoring the limit switch then stops cause of the alarm status…

Your switch is not being recognized.
Hold the switch down and send a ? to the controller.
Paste the response here.

What sender are you using?

1 Like

I didnt read well enough, as Neil says the switch isnt recognized. (not reading the trigger)

If you use Easel it will display a “light icon” for each limit, which will turn green when registered.
Are the switched wired normally open (NO) or normally closed (NC)?

If that is the Version 3.4 board (can’t be sure from photos), on mine the Z and X limit switch pins have reversed markings.

Figured out!

on my Board, X and Z pins are switched…
I plugged Z limits on X pin and X limit switches on Z pins then It works as what I wanted.

I’m not sure what it will cause on this machine. I’m thinking that the manufacturer labeled it wrong (this is what I hoped)

Thanks guys