Gshield won't turn on

I looked in the forums. Basically my machine was working and now it’s not. I cleaned all dust out(not much). Turned it back on and green lights won’t come on, I tried all USB ports, reloaded adruino, but green lights won’t turn on no matter what I do. I rewire everything. Can’t figure it out. Any help is greatly appreciated

I really don’t think g shield/adruino is recognizing my USB ports. How would I fix this? I just have no idea.

I’m running Windows 10 on a new computer 4 months old

E-stop?

1 Like

Isn’t that only on the x controller?? I just have the old set up

Yes… i’ve been drinking Christmas cheer all day. Likely no good advice coming from me… :slight_smile:

Good luck Sean… I am certain someone else will lend a hand…

2 Likes

If you were able to reload grbl into the Arduino then your USB port is working.

Do you get the blue LED on when you turn on the 24 volt power supply?

1 Like

Yes I do get the blue LED light on. When I try to load grbl using x loader it says uploading, but never loads it says “upload failed”. I was only able to reload audrino program that’s all

I don’t understand. If you get the “upload failed” message then the Arduino program did not load.

Which program are you saying loaded?

When you first set up the machine you have to download the adruino drivers for the machine

http://x-carve-instructions.inventables.com/xcarve2015/step16/

Ok, so it might be a USB problem. Check to make sure that you have the correct baud rate (115200) and the correct COM port set up in Xloader.

If those settings are correct, remove the gShield from the Arduino and try to reflash grbl again.

1 Like

Merry Christmas!

Well I tried reflashing it. When I put the hex file into the xloader. It says upload failed. I get no green lights at all. Only still the blue LED light.

@SeanNaylor

With power off (both 24 volt and USB cable unplugged) remove the gShield. Plug the USB cable back in and try to flash the Arduino without the gShield plugged in.

Does Xloader load in grbl that way?

So I tried what you suggested.nothing changed or lit up or went off. Totally out of ideas now

You mentioned that you tried multiple USB ports, but I didn’t see anything that would indicate that you tried a different USB cable.

That would be the last thing I could think of to try.

Most likely the Arduino is bad. Since you can’t reload the firmware without the gShield connected.

At this point, I think Phil has the best plan. Contact Inventables and see what they recommend.

2 Likes