Has anyone found trouble using inches with Chilipeppr for PCB milling?

Here’s a screenshot that shows the issue I’m having right now…

So I’ve tried using the GRBL and XPIX workspaces. Everything on my board is 0.1", so unlike usual I made the board file in inches. I used flatcam to process the trace, excellon, and cutout gcode. All of that worked just fine.

It seems though that the Chilipeppr autolevel is incapable of operating in inches. Has this been your experience? Do you know of any workarounds?


Auto-Level would have to get forked by somebody to support inches. I always just work in mm and since there’s only so much time in the day for adding code to open source software I just made the minimum viable product. It would take the community to add the inches feature. I don’t think it would be super hard. I think perhaps just provide a radio button for picking inch vs mm. Then make sure to put in the G20 or G21 in the generated gcode. Not even sure any conversions of mm to inch would need to happen then.

There’s some good new videos on the homepage of ChiliPeppr now on how to fork the workspace and fork a widget to tweak it.

Once there’s a working widget I would be more than happy to pull it into the main workspaces that everyone uses to have it be the new standard widget.

Hey John, thanks for responding. I’ve since just decided to always design boards in mm. I almost always did already, this was an odd circumstance where everything was 0.1" spacing and felt like mixing things up. Note to self: don’t do that.