Help. Bit is raising too high upon start of program. Affecting final depth of cut

Sorry if this was already address. And sorry if my typing is incoherent. I have been scratching my head on this one. Any advice is greatly appreciated. These forums are a life saver.

So I use v carve desktop to design and save G code files. I use the “x-carve in.” Post processor in v carve.
I use easle to send the g code.
I have the original x carve with the ardino g shield.
I set the bit at “home” x 0 y 0 z 0.
Z0 is the bit touching the top of the stock material.
In easle I have to click “raise the bit” the bit raises a little. Then I turn on spindle. Then I click “spindle is on”
Then i click CARVE.
at this time the bit raises even more. The z raises to the absolute limit of the +Z .(i have no limit switches) Makes an unpleasant noise. Then comes down and begins its cutting. But at the end. It is way too deep.

I believe that when it hits the top of the z. The machine thinks it is higher than it is. Causeing it to come down deeper than it thinks it is.

I also noticed that v carve says its home is X0 Y0 Z .8 I cant figure out how to change this or if I need to.

I also have the safety height in vcarve set to .3in.
I have never had this issue before. Or mabe this is the deepest cut in the tallest material I have ever atempted. But I know it could do it. If it didnt make that extra Z+ maybe I will have to manually edit g code. But think I shouldn’t have to.

If you are sending g-code to the machine with easel you should be using the easel post-processor. In easel click Help then downloads and choose the vectric post-processor.

1 Like

In v-carve under material setup you can change your Home/Start position and change z to a lower point.

1 Like

Make sure your post processor adds a G90 command. I had the same issue when I cut my first Vcarve generated Gcode. I’m not sure if Easel adds a G90 or not and it can affect things.

The noise you hear on the Z axis is probably the stepper trying to move the axis up and it’s skipping steps because it physically can’t move. This means when you actually get to the cutting, GRBL thinks it’s higher than it physically is and hence why you get a deeper cut.


Thanks for your help. In fact the G90 command was not in the code when I was saving under the “X-carve inch” post processor from v carve. Although the program did seem to work. When I resaved the Gcode using GRBL inch post processor. I see the G90 command.

Also I could read in the code that it was first going to Z .800in. this was too high. I reset it by clicking the Set button under the material set up at the top of the tool path section. I was then able to set the Home/ Starting position to Z .300in. (my z safety height)

I was able to download the vetric easel post processor. and follow the easel instructions to copy and past it into the Post P folder from the file menu “open application data folder” in Vcarve, I don’t know what this does. I do not see it listed as an option for post processors when I save a tool path.
But that does not seem to matter. It will import the g code and run regardless.

Thanks again. feels so simple when I look at it now.

You want to put it in the My_PostP folder instead. After re-starting the program it should show up as a post processor option when you save a tool path.

1 Like