Help get Spindle PWM and on/off with chinese 1.5kw spindle

wAnyone got this setup and use the connection from Xcontroler to turn spindle on/off and rpm?
I tried to setup in the menu of the spindle control for external trigger and this work if I use a wire to enable spindle on/off between ground and FOR. This does start the spindle. But signal from the xcontroler to adjust speed does not work. Trying with easel only for the moment

I have one of those VFD’s
I wrote a lot about them in another thread.


In that thread I have 2 diagrams that show you how to hook up to them.

I just noticed you are showing a 1.5KW unit…
Those are heavy hope you have some beefed up frame for it.
I opted for the .800Kw one. Its 7LBS!
I also created my own mount for it that attaches to the small mount plate.
3d printed it and it works perfectly. Fits it nice and snug.

That is how I got my setup, but the ACM/VI does not work with easel. Not tried with universal g-code sender, so that might work. I`ll check and post my finding

Hmm I do not use Easel anymore.
UGS is what I was using before the change to Mach3

I did this.

did it work for you?
I have controller settings if you need them. There is a manual that was posted that tells you everything.

Thank you… I am going to try this when I get back home. I did try to hook up Spindle 0-10 and GND to ACM+VI earlier, but it did not work.

Tried both with easel and UGS. Might be that I need to change some other parameters in the menu since I am not sure if I set the pd002 to 1
I know the pd001 is set to 1 and I could trigger the start/stop with DCM+FOR

This did not work :-(. Got the same setup in the menu, but no speed adjustment from either UGS or Easel. Tried to write some speed commands in UGS, but no change in RPM.

I got the new Xcontroller.

The start/stop and rpm are setup in the .nc file:
G-Code
I’ve modified my post processor to include:
This line at the beginning of the file.
M8 M3 S? (whatever rpm you want, 0 - 24000 in my case)
This line at the end.
S0 M5 M9

Using the UGS command line with the VFD switched on. If I type M8 the relay controlling ‘Run’ triggers. Then I type M3 S10000 and the spindle will run at 10000rpm.
Are you using a relay to switch on run? This will connect DCM to FOR.
ACM and VI inputs on the VFD to the Spindle (0-10v) and GND outputs on the X-Controller.
Also make sure you have set $30=24000. (That’s the top speed of my spindle).
Hope this will help.
Since I set this up I’ve had no problems controlling my 3phase spindle.
JV

The relay I got was not triggering, but the range was around 9-12v DC. and the output from the M7 and M8 are 5V DC it seems.

The PWM and 0-10V output both are giving some voltage when I set S + RPM?.. But if I do connect to VI/ACM it does not give me any RPM chang if I first trigger DCM/FOR manualy with some wire.

What setting do you have on PD070? 0:0-10V 1:0-5V 2:0-20ma 3:4-20mA, 4:0-10V,stacked 4-20mA exterior pulse to input

When I measure vith voltmeter I get some voltage on PWM when I set M3, and M5 cut it… The M8 or M7 trigger the MIST and FLOOD output with 5vdc. The 0-10 go max to almost 10v when I set S24000 and follow when I adjust the speed with S commannd.
But the Huanyang inverter do not change any speed when I set different S command to ACM/VI

You keep on saying PWM. Don’t use that - Repeat DON’T USE THAT, you connect V1 to the SPINDLE (0-10v) terminal.

i.e.>>>>To control the RPM I connected the ACM and VI inputs on the VFD to the Spindle (0-10v) and GND outputs on the X-Controller.
I hope this gets you going.
JV

I finally got it working. It was two fault that I did. One was that I did not change the position on the jumper, and other was that I changed between using PWM and 0-10.
When the jumper was changed, then everything worked like it should. At the same time I factory reset my FDV, so I also had loads of settings to change before getting everything working.

Thank you for helping :ok_hand: