Inventables Community Forum

Help - machine not going to start location

Hi all, trying to carve a very simple project. I set my work zero and the spindle decides it wants to go off on its own tangent when I tell it to carve.

Looking in Machine Inspector and it says the machine is at x:25.908mm y:25.908mm and the workpiece is at X:0 Y:0. I have run a simulation to make sure there is nothing out in la-la land that it is trying to carve first before running the carve.

My standard workflow
Plug Machine In to Laptop
Open Easel
Home Machine
Move Machine X:1.02" Y:1.02" Z:3"
Confirm work zero on X/Y
Probe for Z
Carve

I have been doing this for as long as I have owned this unit, 6 or so months and now it wants to act a fool.

Any ideas on why this would be happing?

Can you share the file?

Here you go like I said it is very simple.

The simulation does not show anything strange. Did you check your grbl setting to see if anything has changed?

Yes, sir, I have even done a new machine step to see if it would fix it.

I think i saw something about the set up a little while back that was making changes that were maybe for the pro and not the xcarve. Are you running a stock xcarve?

Nope, I have the x-carve pro 2’x4’ version.

It’s so odd, I ran that file made a small adjustment meant to fit another board, ran it again, made a small adjustment, ran one more time. Then boom it now just takes off to the back right-hand side.

Sorry did not realize it was a pro.You will need to wait for more help.

All good, thank you.

1 Like

Are you selecting “use last” for x,y
Or “use current position”?

This really sounds like “use last” was selected by mistake

I am setting a new position every time.

Hey. I’m going to jump over to the FB post, the notifications work better for me over there… if anybody else has seen this though it still isn’t resolved and if they could provide another point of view that’d be great

Turned off beta testing and boom it worked. Not sure if they had an update or something but good to go now.

1 Like