Inventables Community Forum

Help please! skipping steps

Hi, i have a little desktop cnc. It has nema 17 motors (2.1 oms on both wire pairs) cheap 3 axis grbl controller no limits with ugs running it and all axis move very nice and smooth. It is skipping steps when running a gcode file like it has 0 power but when I jog it even with speed and acceleration high it has a lot of power even if i push on it when moving, the holding power is really high also. $1 is set to 255 so it is holding. I have set the driver current to 690mv, I got a new control board and tried that… no change, done every youtube setup tutorial, and I shielded my spindle wires. The motors and drivers are not much above room temp.

what machine type is this? It sounds a lot like a 3018 or similar

Also, can you post your Grbl settings, that would help identify the issue for sure

However with what you’ve explained so far it sounds like your Rapid Speed or Acceleration might be set too high. I believe that UGS uses a set feed rate (usually lower than the rapid) for manual jogging, so that could explain why it’s not going into internal lockup when you manually drive through UGS.

it is a modified 3018.

$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 4 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 1 (Status report options, mask)
$11 = 0.010 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 0 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 500.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 1.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 400.000 (X-axis travel resolution, step/mm)
$101 = 400.000 (Y-axis travel resolution, step/mm)
$102 = 400.000 (Z-axis travel resolution, step/mm)
$110 = 1100.000 (X-axis maximum rate, mm/min)
$111 = 1100.000 (Y-axis maximum rate, mm/min)
$112 = 1100.000 (Z-axis maximum rate, mm/min)
$120 = 150.000 (X-axis acceleration, mm/sec^2)
$121 = 150.000 (Y-axis acceleration, mm/sec^2)
$122 = 150.000 (Z-axis acceleration, mm/sec^2)
$130 = 200.000 (X-axis maximum travel, millimeters)
$131 = 200.000 (Y-axis maximum travel, millimeters)
$132 = 200.000 (Z-axis maximum travel, millimeters)
ok

1 Like

I believe it is more than a acceleration because it never catches up it just makes a awful noise as it goes across at about the speed it should just noisy and not to the right place.

1 Like

ok well it might be so far im finding it in the drilling operation only. and im going blazing fast with no skips in adaptive.

1 Like

IF your controller has microstep adjustments, adjusting these can provide more torque at a microstep set closer to 1, the more detailed the microstep, the lower the torque strength achieved (1/32 microstepping will have less torque strength than 1/4 microstepping)

in this video James calibrates the max feed and acceleration for his 3018, you may want to follow along and calibrate them for your cnc using this same technique.

I did and i even tried slower. following his way i got all the way to 450 mm/min before skipping. but thank you for the idea.

1 Like

Im open for any other ideas.

ok I just found out it is trying to go over 1500 during rapids but my $$ is set to 1000 and so is ugs.

ugh nope skipping at only 360 mm/min. This is crazy frustrating!

1 Like

If the grbl settings are lower than the command the cnc controller will automatically limit it down, so even if its sending 1500, the cnc wouldn’t travel above the 1000 setting :+1:

Oh, another possibility is that the linear rods aren’t parallel, this can cause excessive friction and lock up sometimes, but usually only near the ends where they are clamped in place :man_shrugging:

Same with a filthy lead screw. I lubricate the lead screw with ptfe dry and that seems to work real well at repelling sawdust too.

You might check if there is micro-stepping enabled. Typical steppers have 200 distinct positions based upon their coils being fully energized. Some controllers try to eek out more positions by partially energizing the coils through pulse width modulation. When not fully energized the holding power is not what it is when fully energized. The rapids and the holding may be fine but you may have issues when it goes to carve. On a machine that small, I would look to turn off micro-stepping if it is enabled.

Typically, micro stepping is controlled on the controller board through jumpers. If you disable it, you will need to adjust your steps per inch settings.