Help plz! Z not cutting at settings i have set

Hi. I have a diy cnc with grbl i have set up every thing, calibrate the steps. I have now one problem, no meter what cutting depth i set it does not go more than 0.3 mm. I am setting the starting point above the wood with a paper. i am trying to make a clean hole about 19mm and when it finish it only 0.3 mm. can anyone help plz?

my settings


Perhaps try to increase your z travel in GRBL? I believe it’s $132? I’m sure someone else can confirm which line it is. Not at my machine right now.

No, $132 define the soft limit range (if enabled) for the Z-axis :slight_smile:


Test and verify:

  • Do your bit reach the bottom if you jog your machine?
  • If you command a 20mm jog is the physical travel also 20mm?

Change $1 from =0 to =255
(In Easel Machine Inspector Console window type $1=255 and press Enter)

Yes if I jog i can touch the printer frame bottom all the way down. Yes I have calibrate the steps when I jog 20mm it go 20mm. Ok I will change from 0 to 255 but do you thing that is the problem?

No, but it should probably be the default setting.

Can you describe your machine? You mentioned “printer”… Is this a converted 3D printer?

No is not a printer sorry for that. I have a 3D printer and maybe I got confuse because I have print all the parts for the CNC.

My machine is a diy with working area of 725mm on x, and 425mm on y, and about 70-90 on z. The movement is on 8mm threaded rode on x,y and for z 8mm rode with gt2 belt.
I am running grbl on arduino uno with cnc shild.
I have calibrated the steps. When I jog I can touch bottom but no mater what I set when I want to curve it does not go below 0,3mm and it drives me crazy. I do know the basics because I have a diy AM8 3D printer but this I can’t figure it out. I have attached a photo but is when I had the y axis 725mm working area now I have change and the x it the 725mm but you can see the machine and get the idea.

Cool machine! Your design?
If you’re not actually cutting, does the machine “cut” the correct depth?
Assuming Nema 17s for the motors? Make sure that Z axis is moving pretty easily.

Yes very good i like it so much. No is not i have find it to thingiverse. Yes they are Nema17. I think is software side not mechanical because when i jog the mm are correct and i can go all the way down, if i had mechanical problem i think i will have discover it by now. As you see in the photo in Easel i have make the hole to go all the way down, when i start the processes it say approximate 1 min to finish isn’t that to quick for 10mm radius hole and 19mm depth?

How are you setting zero?
The reason I asked you to run the test with no stock is to test whether the machine is just having trouble overcoming the forces of plunging?
What spindle?
What endmill?

Got a link?

Easel has no issues generating gcode to cut a hole. Are you using Easel to send the gcode as well?
If you want, I can look at the gcode…post it here.

The link DIY CNC.
Here is the (28.6 KB)
Yes i am using only Easel to design and gcode sent. Plz see the gcode if you find anything. tnx

1 Like

Gcode looks good. Cuts to -20mm.
How are you setting Z-zero?

I have try with paper and with touch plate with same result on both no more than 0.3mm depth. i have try the depth even 40mm but same thing.

Everything points to a mechanical issue. Run without stock to test.

Without stock? What do you mean? You think is has to do with mechanical issue on z axis?

Don’t put anything in there to cut. Just cut air and see if it goes down -20mm from Z zero.

Yes, or a workflow issues with setting zero.

ok i will try it tomorrow and i will post the results.

1 Like

I have fix it. I had to increase vref on steeper drive because it was too low and skipping steps, if i remember correcly is was 0,88 and i set it 1.05 and now i can cut the depth i set in Easel. tnx every one for the help.