Help! Router starts then stops

Ok. I need some serious help - I got this machine last week from a guy who had it working. I added some length to the cable using 20 gauge and connectors. Everything is hooked up correctly and runs but as soon as I hit run in UGS (what I’m familiar with from my old CNC) the router starts up then shuts off, the computer flickers like it lost direct power, and I need to restart UGS for it to run.
I’m using the relay with the router plugged into the normally off plug. Any ideas?
Thanks in advance!

Have you tried removing the spindle control connection from the X-Controller, setting you Z-Height well above the stock surface, and then running as normal? If the controller starts moving the machine correctly then there is an issue on the spindle control side; possibly a wiring issue …? Another thing to check would be the router brushes. If the brushes are extremely deteriorated (or gone) then the router might be producing some large EMI or surge causing things to go awry. Does the router spin freely with no real noise when turned by hand?


Brandon Parker

Just checked! Thanks for suggesting that- it is definitely the spindle control wiring. I need to figure out if it’s hooked up right

I was having some issues like this as well when I installed my IOT relay. What was suggested to me was it was a magnetic interference issue.

I made my wires from controller as short as possible to the relay and also gave them a redneck shielding. Wrapped them in aluminum foil and electrical tape. This seemed to solve the issue for me.

Having said that the controller was still getting cranky sometimes if I try to run another tool on the same circuit. At this point I’ve actually installed a separate circuit dedicated to the CNC and it seems to have resolved all my issues (fingers crossed).

This is what worked for me hopefully it can help resolve some of your problems.


Thanks Mike! I shortened the wires and I plugged the x-control in to separate outlet and it ran! Seems the issue is the relay

The laughable part is I thought I had resolved all my issues and today it’s all gone to hell again. Can’t run anything in my shop without some kind of problem again… was working great now not so much…

Considering making my self an aluminum foil hat standing on one leg toes pointed to the south with other leg, one arm raised in the air pointing north and other hand on the machine… maybe that will work? :man_shrugging:

Is your shop electrical system wired correctly? I saw one recently that was horrendous. It’s pretty scary when you turn on something on one side of a shop and the lights go off in the other just to come back on after the equipment is turned off…

Does your shop have its own load center panel?

To me, that sounds like a Neutral/Grounding issue, but without knowing specifics/seeing it first hand I can only speculate.


Brandon Parker

Let me know if the directional dance works. I’m willing to try it! If it ain’t one thing… :grimacing::grimacing:

I think it’s the iot relay. I was able to plug both the relay and the x-controller into a power strip and get everything to run. Thanks!

Well, I guess that’s a fair question. I know the grounding is good, it’s got 2 separate earth grounds outside. I had an issue with neutral on one circuit sometime ago but was resolved there was a loose connection in the panel.

There is a separate panel for the shop that is fed from the house as a sub. Honestly, the power situation is a bit dicey for the house. Only 100 amp service that feeds the house and shop. However, the stove is natural gas. Virtually all electrical work has been done by an electrician. Having said that I did add a couple of breakers to the shop panel myself. But that is sometime ago, one of which I’m now using for a dedicated circuit for the CNC.

I purchased this machine used from a fellow. I asked him why he was selling it and he said to get a bigger machine, a Longmill. Now, I question that, I wonder if he wasn’t having problems with consistent operation. Having said that the longmill does appear to be a lot more ridgid and eliminates all but one of the belts.

I guess what is frustrating is it worked great for a week or two and then goes in the toilet for no apparent reason. I do the same things in the same shop and all of a sudden the machine is crashing.

My inner caveman voice says “find big rock, smash bad machine”, but have managed to not destroy it yet!


Do you have the controller plugged into the relay? If so it is probably getting turned off when it starts the job, the relay then turns off the controller. I had the same issue. Does the controller light turn off?

I did. I took it out and plugged it into a power strip. Both the relay and the controller are plugged into that and now it seem to be working fine! Probably a bad relay - it seems as if starting the router causes a power surge that trips a circuit when the the x-controller is surging as well