[Help us!] Testing automatic port detection on Windows

Hi everyone,

One of the sticking points using Easel for the first time is trying to connect to your machine. In particular, on Windows computers you have to dig up the COM# of the device, type it in and wait for Easel to connect. On Mac this happens automatically, but until now it hasn’t been possible to do the same kind of automatic connection on Windows.

I was hoping that we could get some help testing this new version of Easel Local that supports automatic machine detection.

WARNING: This is a pre-release that is not intended for general users. If you want your machine to continue working perfectly, please just wait a few weeks for the general release.

If you like to live dangerously, are using a Windows computer and would like to help us gather feedback, here are the steps:

  1. Download the edge version of Easel Local. (This has been updated from bug reported by @KellyHickel)
  2. Run the installer
  3. Reload Easel and try to connect your machine and run a job. You will notice there are no more COM port inputs.
  4. Leave feedback in this thread about whether Easel was able to automatically connect to your machine.
  5. If you encounter a problem that stops you from being able to use Easel, you can downgrade to the most recent stable version by running the uninstaller in C:\EaselLocal\unins000.exe and then reinstalling normally through the Easel UI.

Remember, we are only interested in testing whether this new version is able to automatically connect to your machine. So please only use this if you currently able to connect manually by specifying the COM port.

When leaving feedback, please note your OS version, whether it is 32 or 64 bit, the device you are connecting (Arduino, generic fake-duino, Carvey, etc.) and any other devices that you also have plugged in to your USB ports


Not working for me. Old Dell Inspiron laptop running windows 10, build 10240, 32 bit, com4 connected directly to x-carve arduino.

Poking around, the EaselLocal service keeps going into a paused state, some of the windows event messages attached as text file.

-KellyEaseLocalService.txt (11.4 KB)

Just FYI, after uninstalling and installing the 0.2.2 version, things are working again.


Thanks for the report @KellyHickel, I’ve been testing on a 64bit machine so that might be the cause. I’ll update with a fix (hopefully) soon.

@KellyHickel thanks again for the bug report. I believe this would have impacted 64bit and 32bit computers, it seems that some of the build files got mixed up and it was trying to install the wrong version of one of the packages. I updated the link above, but here is the fixed version that I tested on both 32 and 64 bit windows 10.

Let me know if that works!

Seems to work fine, I did the setup your machine, I didn’t do the test carve, but the axis tests and homing sequence worked.


I tried it and it worked. Anyone else?

Is the link still live ? Having trouble downloading it

I can not get my machine to find the com port with easel either. Have tried numerous things including:
Updating windows
redid wiring- the com port was blipping on and off, not doing that anymore
The computer recognizes that it is plugged in to COM14 but easel can’t find it.

I tried the link above to a fix for easel but it doesn’t work

I see on a few other posts that there is a desktop version of easel and they mention that it could possibly fix the problem with it not finding the com port, how do I get it?

Hi @Andy4us, I updated the link in the post above.

This is now the default version of the local driver that Easel will download if you don’t already have it installed.

Hi @KevinLupton, I’m not sure which posts you’re referring to, but I think any “desktop version” is probably a reference to the Easel local driver that you install to handle the communication between Easel (running in your web browser) and your machine.

I recently setup a new machine for use with the X-Carve and it installed 0.2.3. This version is not able to auto-detect the com port (COM3).

Using 0.2.2 with manual COM port entry, everything works great.

Instructions and link at the top worked great. Just used it to set up a “new” Win 7 64 bit machine with the factory Aurdino on my 1000x1000mm XCarve. Only other USB devices are a mouse and keyboard. Sure makes life easier!

Thanks for supplying this as it fixed my issue.