Help with calibrating XYZ

Soon as I go to the garage I’ll copy that (Post that info from sending $#)

I homed the machine, went to machine inspector and typed in $# and hit enter. this is what it showed:

Not sure if that’s what you’re asking for Neil. Thanks, Rick

I just tried G0X50, hit enter and it jogged right to approx 50mm. I then hit G0X0, hit enter and it jogged back to home. Guess I’ll be brave and try 100mm now.

Well. I just tried G0X70 and back, 100, 150, 170, and 250 and back and it likes me tonight, go figure.

I’m turning the lights off and going in for the night while things are a success. Tomorrow we’ll see.

Without homing enabled, your machine assumes it’s at MACHINE zero when you turn it on. You’re WORK zero is at MACHINE coordinates

MACHINE zero is at WORK X539 Y539. An absolute (default) move to X200 would be a move 339 to the left.

When you home your machine, it (default) sets your MACHINE zero in the upper right, so the movements work as expected.

Actually, how did you get your work offsets to be -539,-539 on a 500mm X-Carve?

Home the machine. Move to your desired XY work zero and send G10L20P1X0Y0
That will reset your zero to where you want it.

Guess I’m not sure whats going on. The very first thing I do before anything else is log in to Easel, hit the “Machine” button on the top toolbar, then set up the machine which includes homing.

Am I correct in assuming, after this homing is completed, looking at the machine the X0 and Y0 are in the left corner closest to me. I dont see any other choices for homing other than what they show in setup.

Good morning Neil. The first thing I need to get straight in my brain is “When you home your machine, it (default) sets your MACHINE zero in the upper right”. Looking at the machine from the front, what are you calling upper right? I want to be on the “same page” as you. the only reason I ask is because of working in the auto industry for 30 years, you’d be surprised how many people don’t know the right side of a vehicle from the left. A lot of people don’t realize that as you’re setting in the drivers seat, the right is on the passenger side(lt hand dive vehicles).
Sorry for going off track but I’m calling things front and back and you’re calling things upper and lower. I know you’re technically correct but I need to make sure so I can call things as you’re calling them. Thanks, Rick

I don’t have a clue.

Back right? As far right and back as it will go.
The standard in CNC is to home at the back right and all work is done in negative space. That doesn’t sit well with most, so Inventables has their machine home in the front left.
When you home the machine, can you get a screenshot of the Machine and Work positions? Or just note them.

That would make sense. Right now when I finish a carve the machine homes at the front left which makes undoing clamps and such a pain because the router’s in the way.

Hi Neil. I ran Easel homing which brought it to the front left corner for X and Y, Z is at the top against the switch. I opened Machine Inspector and entered G10L20P1X0Y0 and hit enter. I then ran the setup again through Easel for homing. These are the new numbers you asked for;
Machine Inspector
Firmware Version: Grbl 1.1g
Easel Driver Version: 0.3.14
Machine position
X: -289.003
Y: -289.002
Z: -1.000
Work position
X: 0.000
Y: 0.000
Z: 68.580

Looks as expected for a 500mm X-carve. I don’t have one (pretend expert), but I think it has a 290mm sqaure work envelope.
Make sure you home the machine. Set your $22 to one.
Send $22=1 in machine inspector.
If your X-carve is modified to be larger than 290mm x 290mm, change the $130 and $131 settings for X & Y.
I’d also change $27 to at least 3 to make sure you clear the limit switches on your homing pull-off.

If you home, the G0X200 should work. Just an FYI…X0, as it is, is currently 1mm from limit switch.

Kind of a letdown tonight. I went in and changed the $22 to 1, and $27 to 3. Then I took a conservative measurement of X which goes from home to right with a total of 440mm. This measurement was done with my new Mitutoyo scale. basically from switch to switch. The Y measured 290mm from home to back, just clearing the back switch.

I changed $130 to 440.0 and $131 to 290.0

I’m noticing that soon as I go back into and set up Easel for another session of carving, the $22 and $27 are still ok but the $130 and$131 change back to a 290 number(default maybe).

Any way to permanently change those numbers?

Thanks again, Rick

Stop going through the setup in Easel.
Use a different sender.

I’ll try that. Hopefully I’ve been making this alot harder than it needs to be. Rick