Inventables Community Forum

Help with Genmitsu 3018 Pro

I came here to try and maybe find a solution to my problem . Other than my lack of knowledge and computer skills. I am new to CNC . I purchased a Sain Smart 3018 Pro put it together and figured out how to download the software after watching a bunch of videos. So I try the offline controller and the spindle works the head moves on the z,x and y axis ,(yes I unhooked the offline controller) on to Candle to try that everything is the same . Go to run the test code. Nothing The screen shows it was sent and processed on the first command 2nd sent up to # 11 after that the rest were in queue. I tried different test codes same thing. I tried UGS same thing .Tried the SD card in the offline controller at first it showed it had printed 11% of one of the codes the next was about 20% and the last one the spindle actually came on for about 2 seconds (this is the only time anything has happened) and it then shut of and it read 2%. I then pushed the reset button on the main control circuit board and tried again. The results were that each code showed that they printed 100% but nothing happend , no spindle , no movement . Same when hooked up via USB.
I contacted Sain Smart of Friday and they asked if I had unhooked the offline controller. I have sent them about 7 e-mails since them but they obviously do not work week ends so I am hoping that I get a response tomorrow. I am thinking that somehow there is no communication between the control board and the stepper motors but i don’t know sh*t I looked in all the paper work that came with my equipment from Sain Smart and I found 3 differnt Adresses for them but no Phone #'s Is e-mail the only way to get Tech support from them

Sainsmart related issues are best addressed through their official Facebook group (not Business Page) with over 17,000 members, there’s always someone over there to provide the right guidance on just about every issue you can imagine.

Thanks I am grasping at straws . i am not getting anywhere with Sain smart themselves and have went to the facebook site and have not recieved any answers there yet. I am not sure if its a software problem or a hardware issue. Being new to CNCing I do not have a clue just would like to use the damn thing and cut something other than my finger. LOL

1 Like

The people here love to help out.