Help with setup, not quite from scratch

I just picked up a Shapeoko 2 from Craigslist. The gentleman showed me how he loaded gcode into Universal Gcode Sender, and hit go, and I watched the machine trace out an appropriate path. So I know the machine works, at least notionally. I haven’t done any work with Arduinos in the past so please assume I don’t know what I’m doing… Now that it’s in my shop, I can’t seem to connect to the Arduino.

Arduino w/ grblshield v5 on it, unknown software, and I don’t know how to look and see what’s there
Acer Laptop with Win7 x64

Here’s what I’ve tried:
Restarting my laptop, a lot
Power cycling the Arduino
Plugging/Unplugging the USB cable at Laptop and Arduino
–> Note: the laptop doesn’t make the normal successful 2 tone (low-high) usb noise, instead I get 3 fast low noises. Also when USB is plugged in, the Z axis LED lights, the Z axis locks and the Z motor gets warm
Tried connecting Universal Gcode Sender, which got error No Serial Ports Found
From within Easel troubleshooting, I found CDM21225_setup which said that was the first thing I needed to install, then restart. When I did that, the Arduino still shows up as Unknown Device.
Easel also can’t find the port the Arduino is connected to.

Please help, no step is too early in the chain. If I need to disconnect everything and do some black magic to the Arduino, please just point me to some instructions. I’m floundering here.


Have you installed the Arduino IDE (driver) on your laptop?

Link to Arduino IDE.

You’re a genius! I’m up and running now. THANKS SO MUCH!!!

1 Like