Help with Soft Limits

I have been searching and reading for the last 2 hrs and am becoming confused.

I wanted to implement Soft Limits, because I will occasionally get over exuberant with the jog keys. Or I will quickly input a value I want to jog and hit the left arrow. Only then to realize, that my fat fingers added an extra number (2500 instead of 250). I have a 750x750 machine.

I followed @PhilJohnson great instructions for setting this up, and it worked like a charm.

As a test, I Homed my machine, jogged out 10x10mm to make sure things worked. I then intentionally tell it to go right 600mm. It very kindly refuses to move. Excellent. I check the Machine Inspector, and it gives me an

MSG: Reset to continue

I tried:
ctrl-x (by typing it out and by hitting the keyboard keys)
Nothing worked.

I noticed that when I hit the soft limit, it removes the “HOME” button from my “Machine” menu. The Carve button is still green and opens, I just can’t do anything.

Now how do I get it to move again. It seems that the only way I can get it to take commands, is to completely unplug/plug the usb from the x-controller, re-home and start over.

Is this the only way to resume work or is there a GRBL command I can use.


I was playing around with CNCJS last night and hit the soft limits. Reset, $x and re-home worked ok for me. I haven’t tried it in Easel or UGS yet. Hopefully won’t have to… :grimacing:

Thanks for the quick respnse. Your right @PhilJohnson ,it’s still better than a crash.

1 Like

AndyF, could you please explain the process of setting up soft limits. I am also using cncjs and I know that I should enable it using $20=1.

How do I configure the limits?

A response will be highly appreciated.

You might find this useful: