Help with work Zero in Chileppr

Hey guys. I’m trying to use Chilipeppr to mill my first PCB. I’m having trouble getting work zero set. I’ve defined zero with the buttons to the left of the “Axes” widget, but that doesn’t seem to set work zero too? It works for when I run the auto leveling probe job, but how do I get my work zero set?

Also, when the probe job fails, what is the process to get it to start over again? Ctrl-x?

So far I’m finding the whole process super frustrating. I’m using the Z probe included in with my machine, and have the red probe end clamped down to the work piece. I can’t seem to get all the way through an auto leveling probe job without it failing for no apparent reason. And when it fails, everything locks up. The only way I’ve been able to get things going againg is to unplug the usb, then completely reset work zero again. I just forgot to do that, and my bit got plunged into the workpiece, breaking it and leaving a giant hole in my piece. What is the proper way to make this work? Any advice? I’ve watched the tutorial video on auto leveling, but I’m really struggling to get any kind of workflow in Chilipeppr.

I found online that some people had luck with the /imania fork of Chilipeppr for problems with auto leveling, but it didn’t work at all for me. I changed how my wire is connected to the copper board and I’m trying it one more time today.

Failed again. Always in the far right reaches of the board.

When you say the auto-leveling failed, do you mean that the electrical connectivity never seemed to trigger? That would be a hardware failure rather than ChiliPeppr. Or, do you mean the software crapped out? The software simply gets a response back from the device, which I guess in your case is Grbl, that the probe finished. Does the probe just not finish?

With respect to restarting, there’s a stop/pause/play button in auto-level widget, so you just hit play again and it restarts from the first point.

I get a message that says Probe Failed! And then everything completely locks up. The bit never reaches the board on that failed probe that I can see, no matter how deep I set the max z depth for probing. The only way I can get the machine to unlock after that happens is to unplug the USB and plug in again. Otherwise the alarm code never appears in the control window. Once I do that, I have to reset my zero all over again, and start again.

I just found this command for setting work zero, hope it works for me:

  1. Home your machine
  2. Use commands or buttons to navigate to the location of the position you want your machine to use as it’s working x/y/z (corner of your vacuum table, for example).
  3. Send this command: G10 L20 P1 X0 Y0 Z0 "

Grbl likes to lock itself a lot, so indeed this sounds like something Grbl is doing, not ChiliPeppr. You’d have to explore Grbl’s nuances a bit more.

I’d love to see the extra G54, etc controls that the tinyg space has in the grbl space!

The best thing to do would be to fork the TinyG widget and tweak it to support the Grbl differences. Or you could try to add them in the existing Grbl Axes widget. That is a different codebase to some degree between the two widgets because of how Grbl sends stuff back very differently.

There’s many things I know about and can do, including building a tube amp from scratch and designing audio circuits for guitar pedals, but programming is not one of them. I’m sure I could learn it, but the issue is that I have things to make for customers, and adding even more time to the already steep learning curve of CNC is not something I really have time for. Chilipeppr is a wonderful thing, and awesomely free, and I appreciate that. But I’ll have to keep looking for something that works for me and my machine. Lots of people seem to successfully mill pcbs, I just need to find out what they use.

Well I finally got an autolevel to finish. I changed some settings, and made the autolevel area a bit smaller.

Now my main problem is, my grbl file won’t go to/start at zero. I set zero via the Axes controls, and then send a G10 L20 P1 X0 Y0 Z0 command as well. But the file is always offset a bunch down and to the left, and I can’t figure out how to get it started in the right place. I even went back into the Flatcam generator and tried to program in an offset, but that didn’t work.

Any ideas anyone?

It’s a problem with my Diptrace file! I didn’t have the lower left corner set to 0,0 on x and y.