High Pitch Whine after firmware upgrade

I recently updated the firmware on my gshield/Arduino. After doing so, I now hear a high pitched whine coming from the motors. Is this normal? I’ve never heard it before.

Which firmware you installed
Did you erase your eprom before updating

To be honest with you, I’m not sure which I updated. I followed the instructions of updating through easel.

This is an audible noise and it’s in every position when the motor is ready to be engaged.

Sometimes a firmware upgrade changes the grbl parameters. Post your grbl parameters here.

1 Like

My bet step idle = 255 :slight_smile:

Not sure how to get the girl parameters

if you are using Easel you have to go to the machine inspector to see the parameters.

I don’t use Easel so I can’t help with the exact instructions.

If you use a different program than Easel, which one?

In Easel it’s Machine -> Advanced -> Machine Inspector and then in the console line enter in “$$”. You should get a bunch of lines back…those are the settings.

I think they’ve added the Settings in the “Settings” field under machine inspector as well.

Here are my current settings

$132=100.000 (z max travel, mm)
$131=790.000 (y max travel, mm)
$130=790.000 (x max travel, mm)
$122=50.000 (z accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$120=500.000 (x accel, mm/sec^2)
$112=500.000 (z max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$110=8000.000 (x max rate, mm/min)
$102=188.976 (z, step/mm)
$101=40.000 (y, step/mm)
$100=40.000 (x, step/mm)
$31=0. (rpm min)
$30=1. (rpm max)
$27=1.000 (homing pull-off, mm)
$26=250 (homing debounce, msec)
$25=750.000 (homing seek, mm/min)
$24=25.000 (homing feed, mm/min)
$23=3 (homing dir invert mask:00000011)
$22=0 (homing cycle, bool)
$21=0 (hard limits, bool)
$20=0 (soft limits, bool)
$13=0 (report inches, bool)
$12=0.002 (arc tolerance, mm)
$11=0.020 (junction deviation, mm)
$10=115 (status report mask:01110011)
$6=0 (probe pin invert, bool)
$5=0 (limit pins invert, bool)
$4=0 (step enable invert, bool)
$3=3 (dir port invert mask:00000011)
$2=0 (step port invert mask:00000000)
$1=255 (step idle delay, msec)
$0=10 (step pulse, usec)

Your parameters look fine.

Do the motors make the noise only when the machine is idle or do they make the noise when the machine is moving?

Do all of the motors make the sound?

I ran a couple without the router going and they make noise when moving too. I wonder if this and my other issue is related. The first movement on the x axis is less than what is expected. I expect it to go an inch it goes 15/16 of an inch. Every inch after is a full inch. Again, not sure if it’s related or not.

Go back to the machine inspector and in the console line enter $I (that’s capital I as in India).

Post the response here.

Did this ever get resolved?

I have the same issue after upgrading to 1.1 from .9 grbl.

Starts the noise as soon as it connects with the laptop I use to run my x-carve. I did notice it stopped after I ran a job, but upon restarting it does it again.

I also have the regular gshield/Arduino combo as well.

Check and confirm that GRBL parameter $1=255 (step idle delay, msec)
This mean that the steppers are energized 100% of the time and this can make a whine/high freq. hzzz-sound.

Other than that - dont worry about it.