Home point with the laser

I have an x carve machine with a jtech 2.8 laser on it. I’m using the Lightburn software like jtech suggested and I’m having a hard time establishing the home point ( I think Lightburn refers to it as “origin”. Can anyone help me out here?

Read up on negative workspace coordinates. Lightburn is setup for positive workspace coordinates, but the x-carve works with negative numbers. I use macros in lightburn to set everyhting up correctly, and haven’t had a problem since.
I’m not at my computer so I can post my settings later if that would help

I don’t use Lightburn. but I do use grbl. Grbl works equally well in positive space as it does in negative space.

Sam, thatd be great. Thanks

So these are the macros I have setup in the console tab


Untitled 2

Untitled 3

Untitled 4

Untitled 5

Untitled 6

1 Like

Use Laser fixes the negative workspace issue
Laser Mode On & Spindle Mode On changes the $32 to the correct setting for the machine that I am using.
Use CNC resets the workspace coordinate system to X-Carve default
Reset Zero sets my X,Y work origin in Lightburn

I hope this helps

Thanks for the info Sam, I wish I was as computer savvy as you are. Are these changes made all in Lightburn, or is there another program that you use. Thanks again for your help.

All in lightburn. In the console tab, you have macro buttons that you can customise.

Thanks Sam