Inventables Community Forum

Homed Machine Zero not reading X0 Y0 Z0

I have a question about Machine Zero NOT work zero. I have two machines, a X-Carve 1000 with the old controller and a X-Carve 500 with a X-Controller. Both machines are on different computers (Windows 10) using UGS 1.0.9 and doth machines work well on both Easel and UGS. Using UGS when I home the X-Carve 1000 the “Machine Zero” shows X-0 Y-0 Z-0. This is what I would expect. However when I home the X-Carve 500, UGS shows the Machine Zero at X-289 Y-289 Z0. To get UGS to read “machine zero” at X0 Y0 Z0 I need to move the router to the upper right corner. I would like to change this because the 500 machine will not hold the work Zero after I shut the machine down and the 1000 machine does. I have checked the wiring and that is right to the instructions.

Do you know how to edit the configuration file for grbl? You’ll want to enable ‘HOMING_FORCE_ORIGIN’.

G10 L20 P1 X0 Y0 will set work zero and persist across power cycles and resets. How are you setting work zero now?

Use Xloader to install one of these; your choice.

grbl_1_0_c_20161011_Positive.hex (79.9 KB)

grbl_1_1f_20170417_positive.hex (84.5 KB)
.

1 Like

I just turned it on and did not know that it needed to be set I thought that the homing switches set the Machine Zero. I an NOT talking about work zero

LarryM I am sorry but I have no idea what you are talking about, I run CNC but know nothing about the firmware.

Yes, that is correct.

CNC machines, mostly follow a convention that the work area is in negative space. By default grbl (X-carves firmware that lives on the controller) places the work space in negative space.

You can modify grbl so that it works in positive space, however, the way that you tell grbl to work in positive space is that you change one of the compile time options in grbl.

The two .hex files I attached have that compile time option set, so you don’t have to learn how to rebuild grbl.

If you want to use them then you have to upload one of the files to the X-carve controller (works with Arduino and X-controller). you would need to use something like Xloader to update your firmware.

Xloader and instructions can be found here.

1 Like

I understand that, but you stated in your original post that your reason was to get your work zero to persist when you shut the machine down. Your machine position does not matter for that.
To get the machine position to 0,0,0 when homing in the negative direction, as you are, there is a setting in the firmware. That setting, mentioned in my previous post, is usually default for the X-carve. You can simply use the file and method @LarryM mentioned or read the info on updating firmware that inventables shared.
https://inventables.desk.com/customer/en/portal/articles/2058884-how-do-i-re-flash-grbl-to-my-x-controller-arduino-

Not really. The G-code command mentioned here will set Work Zero in G54.

G10 works with Machine co-ordinates, so for this to work correctly you need to home the machine.

There is another way, but the alternate method to set Machine Zero is nowhere near as accurate as homing.

1 Like

WORK zero, completely what I meant… Thanks for the catch. I corrected my post.

1 Like

Thanks Larry M I will try that tomorrow