Homimg Y axis does not work

when homing the X and Z limit switches work but not the Y, I have checked the switch and it’s working okay, I have also run a short length of wire from the switch to the pin on the G shield (pin 3) and that did not work all the wiring is correct I just don’t know what to try next, any idea’s


Look in here for the article on using grbl to debug your homing switches.

Thank you Larry, I have read that, and followed your instructions, the return message I get for the Z and X are that they are both working okay, but the Y return message is 000 open or closed it is still 000, I have tried a new switch and run a cable from the switch to the G shield pin3 in case the wiring was faulty, but nothing works, I have ordered the Xcontroller which should be here early next week so I might wait until I get that before I make any more changes, as the grounds on the Xcontroller are seperate which might be better than having them all bunched up with a pigtail going to the terminal

Thank’s Phill. I tried the jumper from pin to ground and did not get a 1 also reseated the Gshield and still nothing

Most likely a bad Arduino port. You could try to re-flash the grbl firmware to see if it’s a software issue.

I tried re-flashing the grbl but that made no difference either, the Y axis will not stop, so do you think it is the Arduino that is the problem, as I am getting the Xcontroller next week I think I should wait and see if that works first, and if it does I can be sure that my wiring is ok, I am pretty sure it is ?


The grounding issue (pigtail vs X-controller) should not make any difference other than being just a little bit more convenient on the X-controller.

Since you have already ordered the X-controller then you might as well wait if you are not in a hurry. If you don’t have plans for the Arduino/gShield and the X-controller works, then no need to worry about the Arduino.

Thank’s Larry
I am not in any hurry so will wait for the Xcontroller to arrive, I have no plans for the Arduino/gShield, I suppose the Arduino is non repairable anyway. I don’t understand why it packed up, and I would like to know just in case it happens again, did I do something wrong, it might be the pins, I should just bin it

Not likely that you did anything to cause the failure. If the Arduino has the plug in chip you may be able to fix it. I would keep the Arduino/gShield just as a back up.

Okay, thank’s I will keep it as a back up