Homing sequence not offered on every carve - bug?

I just finished some test carves intended to set motor current and found that despite the fact that I have configured Easel to use my limit switches that the homing sequence is only offered the first time I launch a carve in Easel, and then not after that until I completely exit and restart Easel.

I think this is wrong.

For starters when I was doing the test carves I didn’t really care about the Z home position, but one time I started a carve the Z was almost home, so the raise the bit button caused it to crash into the switch (bending it a little). But when the homing sequence is run and the Z is home, the raise the bit seems to know that it can’t go any higher and doesn’t cause the crash.

In any case I think that every carve should be completely independent, so if the first carve allows you to run (or skip) the homing sequence then so should any others.


I’m not sure I agree that every card should be independent. I think you have a valid point and, at most, it should be a configurable option: Each carve independent vs. use last Home Position. I would hate to have to home it every time personally.

Out of curiosity, why would you not want to home every time - just the time it takes? It seems to me that if you home and then set the work origin you’re always starting from known and (theoretically) reproducible coordinates. You just have to keep track of the x,y,z offset you used from the machine to the work coordinates. This would seem to help a lot in the case of multi bit carvings. And the option to skip the homing sequence is built into the homing sequence screen.

Steve, Fair Question: I do a high volume of signs in production runs and every little bit of time saved is helpful. The old saying “Time is Money” applies here.

Here’s why (for me anyway): When a carving is done, it always returns to the home x and y coordinates. And Z for that matter but it’s in the Z safe zone. When you use the previous home position, you save about 2 min per sign. I do 20 signs a day sometimes so, 40 minutes is another two signs for me.

The other reason this works for me is that I have a rail mounted on my waste board for both the x and y axis. When I put a new piece of material in it, I flush it up against both rails and I know that my lower left corner of the material is at zero based on where my homing switches have been configured. So when you’re doing volume work, homing every carving is a money-loser, at least in my case.

Everyone has a preference and by no means, do I have the market cornered on being right. All I know is what works for me and having the ability to skip the homing works well in my workflow.

Interesting. So when you power up for the first time each day you manually set a home position and then keep that live for the rest of the day? I’m a little surprised that you don’t set the limit switch home stops to that position so that the homing gets you to right where you want to be automatically, then carve right from there. Unless I’m missing something (quite possible) that would save you even more time. Or is your model home not in the bottom left corner of the drawing? I’m also a little surprised to hear that Easel is being used for high volume work, I’d have guessed that there is a more optimized solution.

My homing switches are set to line up with the rails on my waste board. I home it once at the beginning of the day and am able to keep it at that point for the rest of the session; which could be the entire day. Every time I’m done with a carve, it returns to the x and y position, z is in the safe area. When I go to the next carve, I select the option to use last home position (which includes the z at the 0 point - i.e. the surface of the material rather than the safe position). It moves to where it’s supposed to start carving and does its thing. As long as I don’t accidentally pull the cable out between the two, or lose power, I don’t have to home the machine again until the next time I power it off and restart it.

With UGS, I would have to use Easel to home the machine after every carve. Then I’d have to set my bit on the surface in UGS reset 0 in all three axes, and then start the carve. I’d lose 2-3 minutes between each carve just for this process. Furthermore, I could not get homing to work in UGS consistently.

The only con that Easel has presented me so far is if their server is down or my internet is down, I can’t use Easel. I then have UGS to fall back on until service is restored. The fact that I can use Easel has cut my time between carves in half or more. All of those minutes add up during an 8-10 hour day.

I’m with Steve - many times I’ve run the same job over and over with no need to re-home. A button to home on demand seems to make sense to me - I’m not a fan of the computer taking over and making decisions for me, but I do acknowledge there is a portion of the population that not only rely on that, but requires it for success…

I’m the guy who doesn’t home every job. I think Steve does. I have already proposed a home on demand and the ability to move x, y, and z axis as desired without moving through the job set up steps to @Zach_Kaplan. He told me some of those ideas are going to be addressed by the staff if I understood him correctly.

@Zach_Kaplan feel free to correct me if I am wrong.

At the beginning of this thread I thought I understood but now I’m getting confused. I don’t have a machine near me right now. I’m going to bring this up when the engineering team gets back in January.


  1. start up Easel and select Carve
  2. You get a dialog asking if you want to home to the limit switches (gives an option to skip it)
  3. Then you get the other dialogs and proceed with your carving.
  4. first carve finishes
  5. DO NOT EXIT Easel and press Carve again
  6. The home to limit switches does not appear, but the following dialogs do.
    You have to completely exit Easel and restart to see the home to limit switches dialog again.

My proposed change is that the home to limit switches dialog is displayed (and skippable) every time you hit Carve, not just on the first one in a given Easel session.

@StevePrior what is the scenario where you want to home again when you already homed it?

I’m not sure, maybe I’m new at this, but yesterday I was running several test patterns (without a bit) to set the stepper motor current, so naturally the controller lost track of where everything is. I ended up with the Z nearly homed without the controller knowing about it and slightly bent the Z limit switch.

So maybe this is just something that a newcomer needs for a while when they’re getting started, or maybe it will have a use later on.

I haven’t done this yet, but one thing that comes to mind is when doing multi=stage carves with different bits. It seems that currently the procedure is to change bits while the X-Carve is powered up to keep the zero and keep the stepper motors locked. I’m the type that actually does unplug a router when changing bits - possible with my Dewalt 611 spindle, but wouldn’t be with the old 24V spindle. There is also a chance that you could move the cutter during the change. I would think the safer procedure would be to power down the X-Carve and reference off the limit switches to get you back to the same spot. But I haven’t got there yet.

I will also say that ■■■ a beginner in this I found it confusing at first that the sequence of dialogs was different from the first carve to the following ones. Made me wonder if Easel “forgot” that I was using limit switches so at some point I tried going through the setup procedure again. It wasn’t until after a fair amount of experimentation that I realized that completely restarting Easel got me to the behavior that I was expecting in the first place. So this could very well be a new user onboarding issue.

@StevePrior After some experience, IMHO Homing is not required between cuts.

However, here is how I can force the Home feature to appear when using Easel.
It requires having a momentary switch attached to the ABORT pin on the GRBL / Arduino (pin A0).

Normally when you press this switch it will abort the job that it is running.
Motion will stop.Motors will still be engaged, and spindle will stop. The job is “aborted”.
Easel sees this as well; the progress bar goes away.
If you press Carve, you will be prompted to Home.

Now say you still want to Home after completing a job.
Here is where it gets wacky:
Click Carve, jog and the machine, and press this switch while issuing jog commands.
GRBL will abort and Easel will detect it and offer you to home.
BTW I am not sure if this is a GRBL feature or a bug…
The only way to get the GRBL to abort is to press this switch while the machine is moving.

when i tried to abort through the arduino, i lost home and everything. my entire machine went screwy. had to scrap workpiece

since then what i have done is paused the machine through the arduino and then cancel the progress bar in easel. when i do it this way my machine remembers home and returns to it after wards, well close anyways. for some reason it always returns home but the Z axis does not return to its home position.

so i enter the machine tab and advanced settings. I enter G28 command and the spindle drops to the Z home position. I set this position using the G28.1 command at the beginning of my setup process, i do not know if the Confirm Home Position tab under the CARVE menu is the same thing as G28.1. i assume so, but i am not for certain. I now use the G28 command to return to my zero point in between carves. SO far this has not failed me.