Homing successful, but now no communication (kinda fixed)

I finally got everything assembled and ran the homing sequence through Easel. Connection between Easel and x-carve was great and the homing sequence ran perfectly (and without any smashed limit switches, which makes me lucky I guess!). I got pulled away from the machine to handle a kid issue for about 30 minutes (during which my connected computer went to sleep). I came back and was ready to run the test carve but Easel wanted to run me through the machine settings again. No problem, I thought. Unfortunately this time Easel refuses to connect to my machine. I’ve tried rebooting my computer, and shutting off/unplugging the controller, as well as trying different USB ports, and the result is the same. If it means anything, when I turn the controller “on” all axis are essentially locked if I try to move them by hand and the green light is on. My computer is a Windows XP system. I swear I read a post on here with similar symptoms to what I’m experiencing, but I can’t find it right now. Any advice on what to try would be appreciated.

I’ve had the same issue happen several times when my computer goes to sleep after attaining the green carve button.

Turning the computer completely off and then restarting it has solved the problem for me in the past (sometimes it takes more than one attempt). Now I make sure my computer doesn’t go to sleep with the X-Carve connected.

I wish I could be of more help. Good luck.


I wonder if this has anything to do with XP and a weird thing that happened when I was installing the Arduino drivers? The Arduino installation instructions say that when you first connect an XP computer to the controller that it will be unable to install the drivers automatically (and then it gives instructions on how to manually install the drivers). However, when I first plugged in the controller my XP computer indeed found the drivers automatically and installed them without any action from me. Perhaps it installed the wrong drivers when it did this?

Okay, so going on the theory I might have had a driver issue, I went and uninstalled the Arduino in Device Manager. Plugged the controller back in and this time I made sure to manually select the driver. Tried to install “Arduino_UNO” driver as Arduino said you have to do with XP but I get the error, “this location doesn’t contain information about your device.” The only driver Device Manager would let me install was the regular “arduino.inf.” So I installed that without errors. Back to the setup screen in Easel and, nada. Easel still refuses to connect to the controller.

So, still dead in the water after initial success. All because of the computer going to sleep once. :frowning:

I’m guessing this must be a fairly unique problem so far because I’ve only had one response. I’ve managed to fix the issue (somewhat) on my own. It appears it’s some sort of problem with XP. I connected my laptop that has Windows 7 on it and it connects just fine multiple times. The new problem now is that it refuses to complete the “homing” sequence. It will connect and start the process just fine, and even stops at each limit switch like it’s supposed to. But after it hits all the switches it just stops and sits there with the Easel screen showing that it’s still homing…for 30 minutes so far. So connection to the controller is consistent at least, but can’t complete homing. One thing to another I guess.

I’m glad to hear you got it to connect. I’m using Windows 7 as well. Homing I do not do because my Dewalt 611 hits the upper Z-motor mount before the Z limit switch engages. So for now I just find my zero and start carving.