Homing x-carve causes alarm 8

The x-carve was working normally yesterday, but on startup today, any attempt to home the machine causes the Z axis to drop slightly (rather than move up to contact the limit switch), then an Alarm:8. If I unlock the machine with $X, I can move the carriage around normally and return to zero, but homing still does not work. Any help would be appreciated.

This is usually a broken or loose stepper motor wire.

I don’t have a multimeter on hand, so I can’t be sure, but all connections seem secure, and the z axis moves up and down normally when unlocked.

Check your Z axis homing switch. I had the same symptoms after my switch went permanently closed.

The controller was trying to move the router downward to open the switch, and then alarmed when nothing changed. I replaced the switch and all was good.

1 Like

What sender are you using?

Currently UGS, although I had the same problem with Easel

Try changing the homing switch pull-off ($27).

It is normally set to 1. Try something like 5 to see if that is the problem.

I think this would happen if it was detecting the limit switch as pressed. Can you post your grbl settings ($$)?
Can you post the status report (?) from when you reboot the machine?

A bad limit switch seems to have been the issue. Swapped it out, and we’re back up and running. Thanks all!


Hi, the same thing is happening to me on my machine. Could you give me more clarity on how to fix it? … My limit switches seem to work fine.

Can you give more details?

When I run $H in UGS all that happens is the spindle goes down 4 or 5 mm. Then the message is ALARM: 8. This is my current setup:


Sounds like your Z switch thinks it’s triggered?
Send ? and paste the response from grbl.


Can you connect the machine to Easel and open Easel’s Machine Inspector?
Short key CTRL+SHIFT+D

Machine Inspector will show three “LED”-icons, onve for each axis. With it you can test the switches manually, and the icon will show green when switch is triggered.

Relevant GRBL-information regarding homing in general:

It’s great that Easel feature. I did the test and all three switches work fine. But I tried to do Homing from Easel and the symptoms are the same. I still can’t find my problem. What GRBL version do you recommend installing on Arduino Uno? …

Ha! Ok, that’s not what I was hoping for. There are status reports…maybe you turned them off? i forget how that works in UGS.
Anyway, you’re sure you’re switches are working? When you press in goes green, and when you release it turns off?

To rule out other possibilities, in Easel or UGS when you jog, all axis move the correct direction and distance? A 10mm jog command = 10mm travel?

The solution was to install a version of GRBL from the year 2017. The version I was using was from 2019. Perhaps this error could be reported. Currently my machine works very well. Thank you very much for your help.

That doesn’t make sense. Does it home now? Can you post the settings (which probably reset)?