Homing. Z axis just moved down very slowly?

If I click the home button, my z axis lowers very slowly (it should be going up!!). This is all that happens. Any idea what’s going on?

Even if I hit the limit switch by hand nothing happens, just continues to lower the Z.

Did you do the machine setup in Easel?

It’s nothing software related :slight_smile:

Machine setup establishes the correct firmware settings in Grbl to make your machine behave.

I understand :slight_smile: The firmware hasn’t been touched since my last calibration. I literally turned the machine back on and this problem happened. and unless the arduino re-flashed its firmware without the machine or pc even running, its settings are fine.

Ok, sorry. You didn’t make it clear that you had the machine working and this was a new problem.

Since your Z homing switch didn’t affect the homing operation you could try this:

interesting stuff thanks! I didn’t know that was possible