How can i change the Home position

i have the X-carve 1000x 1000 with X-controller.
how to change the home position.
Righty now the (home) is position is on the BACK RIGHt of the table. it should be in the FRONT Left position.

thank you


Do you have the homing switches on your machine? Are you using easel or ugs?

I can also use some help with this issue. I have homing switches installed on my 1000X1000 X-carve. When I initially started the unit it did home to the front left corner. I had some other issues that I resolved and can carve using UGCS but not connecting with Easel. When it does try to home, well lets say I am on my third z-axis switch. In UGCS when I enter the command $H it says something like “disabled command” I am writing this from and I am not near the machine to get the exact message. From what I have gotten from the forum the GRBL has locked the home position and I have no good idea how to reset it.

When you hit the limit switches, the machine goes into an alarm state. To clear the alarm, you have to send the $X command. Once you do it, you get control back.

So if I enter the command from UGCS “$X” to get out of the alarm state, then enter $H the machine will go to the Z-axis switch, then Y-axis and finally the Z-axis. Then I would like to rest the “Machine Zero” to this location.

Clearing the alarm will allow you to Home the machine again.

To be clear, at least in my version of GRBL, the machine searches for the Z limit switch, then searches for both X and Y limit switches at the same time.

Once the operation ends, GRBL sets this position as the Home position, which is different from (Work) Zero position. This is referred to in UGCS as the “Machine Position”.

Still in UGCS, go to the “Machine Control” tab. There you’ll find buttons that reset X, Y or Z individually or all three at once. Try jogging your machine somewhere else and hitting those buttons. You will see that UGCS makes the current position (or at least one of the coordinates) the new Zero. UGCS calls it “Work Position”.

So, to make it clear:

Home Position (in Easel) = Machine Position (UGCS)
Zero Position (in Easel) = Work Position (UGCS)

I hope this clears it for you. If not, let me know!

i have home switches for x,y and z and im using easel.

I also need help with this, I dont need info on work position and zeroing I just want know what command to write when I have my router in a position say for example left of normal work position, I dont have limit switches

Here is a useful forum thread on how to set the home position:

Have tried over and over again without success. I type $H and get the message that it is disabled. I type in $X and it says OK and to home machine, type $H and get the same message that it is disabled. AHHH!!!

First question that comes to mind is: do you have limit switches? Perhaps there’s something wrong with the wiring and your machine keeps feeling it has hit a limit switch. I’d unplug the limit switch header from the G-Shield and I’d try it again. You may have to disable limit switches in GRBL, but I’m not sure if that’s a thing.

Alternatively, do you have Soft Limits on? If positive, turn them off before trying it again, although I don’t think it affects the Homing sequence. If you are unsure, go to your G-Code sender and send “$$”, then copy whatever comes on your monitor and post here.

I am using “PicSender” and when I click the GRBL SETTINGS" button I get what is displayed below:

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=19 (status report mask:00010011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=1 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.947 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

So, looks like you got some values set incorrectly:

$22 should be set to 1 if you want to be able to execute $H

If you want soft limits, recommended, then $20 should also be set to 1

Give that a try and see if the axes move in the right direction toward to limit/homing switches. If not, you’ll have to adjust $23 to make them go the right way.

I will try that when I get home, and THANK YOU so very much for the assist.

Also if you machine is the 1000 x 1000 model $130 and $131 should be set to 790.

And by the value on $102 I assume you have the ACME rod for you Z axis.

If you have homing switches turned on and enabled, you can set repeatable, recallable workpiece home positions. I made a forum post about using multiple home positions and some of the advanced features of it here.

I use UGS as my G Code sender, but did the initial machine setup using the Easel machine setup. It prompted me to choose whether or not my machine had limit switches installed or not. How I just use $H to home the machine in UGS.