How do you know when you need a new stepper motor?

My x axis motor stopped working shortly after I started a carve. I had just finished a larger carve and was going to cut the inlay to fit in. On a side note I think I upgraded the firmware that easel was telling me I needed to do right before I started this carve. Anyway, the carve started on a nice round cut that looked great, then it had to head straight to the right after that and the motor couldn’t move the router anymore.

I’ve read several things here and i checked the set screws, both are there and tight, the wiring seems correct as the light comes on when I move it with the machine off. When I do try to move the router I sounds like the motor strains, and if I do give is a push it will move with my assistance. I thought it was lack of power to I adjusted the flow to the motor (sorry I don’t understand most of what you guys say, or call things so I’m at the dummies level here), and that did not help it move but it does sound like the motor strains more.

When the power is off everything moves nice and easy. I tried tightening the belt, and I tried loosening the belt. I adjusted the bottom v wheels to make them move easier, and it helped make it move easier when I did it manually but not through easel.

A few months ago I did reinforce my x axis by using bolts going through it as I read somewhere on the forum. I thought it moved a little tougher after that, but it did not seem to effect my carves so I thought it may be my imagination.

I just updated easel to the newest version hoping it was a miscommunication because of the firmware update but that did not help either. The Y and Z axis still work great.

Thanks in advance for your help and remember, small words I can understand please.

Swap your X axis motor cable with your Z axis motor cable and then try to jog the Z axis (which will be connected to the X motor) and see if it gives you the same sluggishness. If so, it’s the motor. If not, it could be the wiring or the controller. Check for any loose connections or broken wires.

Is this a new revision Xcarve or the old one? Xcontroller or Arduino/Gshield?

Ok, so you have altered the current limiter for the stepper driver - what voltage do you read between that potmeter and ground?
It may be that it is set too high causing the stepper driver to overheat during carve?

Great idea. I will try to get that done tonight. It is the Arduino/Gshield. Purchased Dec '15.

I had a similar situation with one of my steppers and it ended up being a broken drive shaft. When powered, it would sound like it was moving but I quickly realized that the shaft on the backside was turning but the shaft with the pulley was not. Mine had shaft sticking out the backside but yours probably has a flush cut shaft. You should still be able to observe movement.

Take the belt off and jog the x axis. If the pulley turns, try to stop it with your fingers. If the motor keeps running and you have.

This could also be a bad stepper driver on the gshield. Swapping the motor to another known working axis would also be important in trouble shooting.

Okay, so it’s fixed and here’s the story. I took Justin’s advice and switched up the X and Z motors. Note to anyone that does this in the future the x axis will move much further than you think because it still thinks it is the z axis and has to turn the screw, so be prepared. So I switched the motors and nothing happened. My father-in-law was helping me and noted that there was no power to the arduino. Ends up I had bumped the power wire loose. Fixed that and now the z axis did not work. Wiring must be the problem, right. So we get some wire to run and quick double check before we pull more wire. Father-in-law notices that some of the wires plugging the x axis into the arduino were already loose. Fixed the loose wires, switched the motor wires back, and wala, my xcarve works again. I had to do my little happy dance. Thanks for the advice and check those wires.