I could not Solder this


I tried to Solder these point, and i did it in wrong direction, so i tried to remove it but i after many times i removed it but remove also the slider point there as you see is the picture. so now i could not Solder it again /
what do you suggestion guys

not sure what you mean by ‘wrong direction’ and ‘slider point’.
If you mean you soldered the pin head to the wrong side of the board, tried to remove it but removed the soldering pads, you can try to use the pads right next to it to overflow into the pin.

This will solve that issue and a lot more

1 Like

pololu.com has a lot of parts and components that are helpful.

I am not sure if this is the correct replacement:

(you snap it of to the number of pins you need.)

Yes this is exactly what happened.
If you removed the traces on the board with too much heat and too many tries soldering,
There is no other way to solve it.
Iam waiting this frim 2 week after lonng shipment.
Any other suggestion like solder the wire directly

By the way why i need these pins

No i dont have limit switchers and i have dewalt 611.
But i order laser from jtechnology. Do i need the pins. And what is PWM

PWM is a square wave signal that has a set frequency but a varying duty cycle. You will need those pins for your JTech laser. It IS technically possible to solder wires elsewhere on your Arduino to make these connections, but if you struggled with soldering header pins I wouldn’t recommend it.

1 Like

The PWM output of an Arduino is 5V. It sends pulses to either a driver which uses a 5V PWM signal for input control, or an N channel mosfet in your power supply interface board (for 24V, 48V, or other DC voltage for your motor) which allows current to flow by sinking the motor current to common. So it doesn’t really pulse 5V, it pulses the current sink valve open and closed. For a laser, it’s used as an enable input on the laser driver for controlling the laser diode duty cycle or brightness.

1 Like

can you please tell me where i can solder wires for laser please

Ok, well each one of those header pins went to a pin on the ATMega328P on the board, the big microcontroller, right? So there are copper traces between the ATMega and where the solder pads were.

If I were absolutely desperate, and I’m not, and you shouldn’t be, but if I were actually this desperate, I would use an exacto knife to scrape the solder resin screen off of the traces leading to where the header pin solder pads used to be and then delicately solder a 26 to 30 gauge wire onto the tiny bit of exposed trace. After they were all soldered I would just dump a massive amount of hot glue onto the board to keep everything from tearing off like a hangnail. And then I would have a replacement Arduino on order, like yesterday.

I wouldn’t recommend you do this, but this is probably your best bet if you’re at the end of your rope and you absolutely need this thing running immediately without any way of getting a replacement Arduino.

1 Like

If you can’t solder very well you could use a device like this one to get your functions back.

You place this device between the Arduino and the gShield and then you can use the screw terminals to attach your wires.

Only downside is that if you do it this way it will not fit in the Inventables electronics enclosure.

1 Like

i only need to solder the pins needed for laser. if you can show it to me where to solder plz

Which pin on an Arduino Uno loaded with GRBL is the PWM output? That’s literally the only pin you need for the laser.

Be careful here. I believe that the JTech laser people use a different version of grbl than the X-carve.

1 Like

It looks like the difference for people running a JTech laser is a reduction of the PWM output frequency from ~8kHz to 1KHz. @YasserSaleemFalahIbr, that’s something you’ll have to look out for, but it shouldn’t change your pinout.

now it is not working at all :frowning:
even after removed the soldered pin the y and x axis not working at all

can you take a close up picture of the gshield where you removed the pins

here you go

is that the actual board? I don’t see any solder, and the pads and traces don’t look burnt out. Try rewiring it and don’t worry about the homing switches or pwm connection yet, first see if your steppers will work. If after rewiring it’s the x and y again and not the Z; try swapping the wires between the Z and X and see if the X moves. You have to try and eliminate the variables so to speak. Also I can’t stress enough, make sure your gShield is firmly placed in your Arduino and all pins are seated correctly.

The gShield pads being clogged with solder should in no way affect your stepper movement. If it did anything, it may affect your homing command not working but not jogging your steppers.