Inventables Community Forum

I got a new laser (Opt Laser set up)

I’ve finished the assembly of my new XCarve and with it the installation os my PLH3D. It’s almost all new for me, but at some point I think I’m missing something.

The Xcarve is working fine with the Dewalt Spindle, there are just some minor adjusts in the belts and squaring it, but with the laser area things are a little more difficulty.

My Setup:

XController PWM (+/gnd), connected to both the IOT relay and to the laser Analog (+/gnd).
From relay I have an output in 127V to the 12V power supply wich send 12V (+/-) to the Laser.
I’m runninf GRBL ver. 1.1f on XController.

Easel try:

Go to advanced settings and change the following:
$30=0
$31=255
$32=1
Draw anything, and send to carve, the fan turn on when I click at the turn on spindle and when I click carve it start moving but no laser at all.

Tried this about 5 times, even in two different computers and nothing.

Reading many of the materials in Xcarve forum, I’ve seen the LightBurn Software as an option, but downloaded it, installed and set as a GRBL controller, with an 1000mm x 1000mm area and go to the working area. Different from the easel, it doesn’t find the XController and all the time say it’s disconnected. Tried on a second computer and the same error.

I usuaaly don’t give up easily, but I’ve read many forums and lots of youtube videos, much of them have different setups, with and older XController or without the IOT relay but couldn’t find an answer. I’ve asked twice in the inventables forum how to setup for some guys who post many things, but no answer.

So i’ve decided to come here and ask for some help. The only difference from your setup instruction is the iot relay, wich I don’t think is the problem once the fan runs when it should.

Any idea?

Thanks a lot!

I don’t recommend grbl version 1.1f for laser users due to the changes it makes in the way G-code commands work. I prefer this version if you don’t require spindle speed and feed rate overrides., but you can get 1.1f working if you read this document and follow the changes.

For my version of grbl use these settings for laser mode:
$30=255. (rpm max) ************* This value can be anything for grbl 1.1f
$31=0. (rpm min)
$32=1 (laser mode, bool)

Here is a good way to handle spindle/laser selection. Change D11 to PWM output for the X-controller and use GND beside it for the Arduino ground.

PWM_switch_example

1 Like

LarryM, thank you so much for your help. Initially I would try and learn well it with the stock firmware, after having total control and understand all this them it would be time for more deeper changes.

So the first step will be making it work in the 1.1f version and trying to use it and see what are this version limitations and see if my working flux is impacted by any limitations.

Looking at the document you recomend for making the 1.1f work with laser, I saw the changes I’ve done in $30, $31 e $32, and those I already know where to do inside Easel (machine>advanced>machine inspector) but I don’t know where to insert those commands like G, S or M. Is it in the same place? Or is there a Command line mode somewhere else?

I don’t have the machine here, but will try it tomorrow in the morning.

Thank you again, for your time and patience.

I noticed that you had $30 and $31 reversed. Have you tried fixing that yet?

I will review it, but maybe I just typed wrong here, I’ve done it a few times, even in two computers following the guides from here… Anyway thanks for your attention to this detail…

When you say it doesn’t find the XController, have you actually selected a COM port? With GRBL, LightBurn doesn’t auto-select because every Arduino has the same USB ID’s, so you have to manually pick. Once you’ve done that it should work fine.

I just tried Lightburn for the first time tonight and ended up with the same issue.

If you look at the devices box, it will be there. Change it from (auto) to the correct com port for your setup and it should connect immediately.

Make sure you don’t have any other control software running such as UGS or Easel.

Hello
i would like to order the Optlasers PLH 3D-6W-XF to upgrade my cnc Router
i need this laser head for marking on anodized aluminum Drones parts
please any help , if this laser can do the job with good results .did anybody tried to engrave on anodized aluminum with this laser head
thanks

Yes. This laser will mark great on aluminum, especially anodized. If the aluminum is raw or clear anodized when marking, you will need to use a marking mask spray, but colored anodized aluminum works great.

thank you so for your help
Riadh

Helllo Samerson did you still need some help with your laser Shoota75@live.com if you do happy to help

Interesting… does Cermark really work with diode (i.e. low power) lasers at slow speeds?

UPDATE:
Quick googling found this

Although it is ‘theoretically’ possible, in practicality, only very thin metals will work. The problem is that metals are a great distributor of heat. Although the laser has enough power to cause the bonding reaction, the metal dissipates the heat too quickly for the reaction to happen.

And from Jtech

With the 3.8W laser these products slightly adhere on stainless, but not to a good enough quality and durability.

Guys! Thank you all for the help, I’ve found all I needed to make it work, now is just a question of time and trial to put it working.

AlAmatea, your tip was a key from changing the port from auto to COM.

The PWM wires were inverted in the magnetic base too. Found it reviewing all the steps of installation.

Thanks for the answer Anthony, right now it’s all fine, but if I need any help I will ask thru e-mail.

Yes, it does. Opt Lasers has a YouTube video of their 6w laser marking on stainless and other materials. Check it out.

But non anodized aluminum in particular? Can it handle it with Cermark (or similar)? All mentions that I found suggest a 40W CO2 or stronger.

Yes it is doable with the 6w OptLasers diode laser. As long as you use Cermak or similar masking.

Not fast enough for production work, but it isn’t that slow either.

I have a diamond drag bit as well, and unless I’m needing the black burn mark from the laser, I tend to use it instead. Zero clean up, faster, and usable for production work with the x carve.

1 Like

I’m having the same issues, Were you able to locate where to modify the G, S , or M commands?

Hi ChadMiller1, after I’ve found the inverted PWM cables and adjusted them and make the change in lightburn from (auto) to COM5 it started working and I’ve found that I didn’t need to change those, at list until now didn’t need.

Thanks you, I haven’t tried lightburn, I am new to the laser community and all the commands that go with it and I have yet to make my laser work at all, Im sure it will be simple once I understand the basics, but I cant get my head around how Easel, GRBL laser, and lightburn all work together. I have connected my x controller to GRBL and created g code and the x carve moves around but the laser isn’t firing( It is wired correctly). I think I may need laser programing for dummy’s. Am I correct in assuming that once your design in Lightburn is complete, you then run it through GRBL to operate the laser?

Hi Chad.

Just wanted to interject something that may help you out.

Easel is not really useful as a laser cnc program. It is based on and designed for spindle carving.

Lightburn is an entirely separate program from easel, and does not interact with easel. In any way.

The laser is turned on and off using similar commands in GRBL, such as m4 and m3, but the strength of the laser is controlled by issuing speed commands such as s125, s355, s0, etc.

The commands given as based on the version of GRBL you are using and the desired laser mode wanted.

Lightburn, and software similar to it, takes care of all this for you.

Without going too deep into it, I hope this helps you understand it a bit better.