I Got Two Problems - Please Help

First problem - when I hit the raise spindle in machine setup the Z axis raises and does not stop. I have to turn machine off to get it to stop. Checked settings in advance menu and it was the .15 default. Works OK when jogging but goes nuts on the raise spindle function.
Second problem - carve starts in upper right hand corner rather than lower left even after zeroing during machine setup. All X Y and Z axis function properly during jogs.
Thanks for any help.

What software are you using to control the machine?

First problem could be your raising in mm but the machine thinks its in inches.
Try raising in smaller increments.

2nd problem need to know if your uisng Easel or UGS?

If your using Easel then try a new blank carve then see if it still starts in the upper right.
There may be a shape up there you have set white (white shapes are invisible.).
Just a thought.

How do I change the increments in the “raise spindle” function during machine setup?
Using Easel.
Thanks for the quick interest/response.

I meant “carve” function not machine setup.

Lower left corner has the inch to mm.

Will take a look and give all suggestions a try. Thanks

Lower left again for the mm to inches setting.
I have not used easel in a while. bit rusty on the interface.

Got the Z axis prob solved I think.
Carve still starts in upper right corner rather than lower left. Started with a new file and tried that but still moves to upper right before starting carve.

GRBL v8. Arduino uno and a grbl shield.

As far as I know there is no way in easel to change the tool start from the lower left to the upper right. this sounds like a problem in the gcode file or a parameter setting like G28 referencing to start the tool at that location.

Using gcode file generated by easel. Is there a way to view the gcode with easel?

Or, the motors are reversed…are you first setting up your machine? Have you run machine setup?

Motors run fine with jog commands i.e. proper direction, speed etc. Just zero’d the machine using UGCS and it works like it is supposed to now - carve starts in the correct position… I must be missing something in the easel setup.

1 Like

When you say it “… jogs in the proper direction …” can you explain what that means to you?

For me, when I hit the UP arrow, it should jog in the +Y direction which would be away from my if I was standing in front of the X-Carve. The RIGHT arrow should move the X gantry to the Right.

Is that what yours does?


Ah Ha…y+ moves forward…let me reverse my stepper motor plug and try again.

Well crap…now the carve goes off the cut area. Looks like zero out with UGCS first and all is good.

1 Like